Upgrade Assistant API Not Responding

Hello,

I'm attempting to resolve an issue with one of our indexes before we perform an upgrade. We're currently running v6.8.8 of Elastic Cloud.

I'm following the docs here to add a default field to our index to resolve the compatibility issue. However, trying to run the API console command from the Elastic Cloud console gives me an error. If I can't invoke the API from here or in Kibana's dev console, where am I supposed to do it from?

This is the response I get, whether using a GET or POST request:

"error": "no handler found for uri [/api/upgrade_assistant/add_query_default_field/[INDEX-NAME]] and method [POST]"

Have you tried putting it into a curl request? eg;

curl -X GET "localhost:5601/api/upgrade_assistant/add_query_default_field/myIndex" -H 'kbn-xsrf: true' -H 'Content-Type: application/json' -d'
{
  "fieldTypes": ["text", "keyword"], 
  "otherFields": ["myField.*"] 
}
'

No I hadn't tried that. Attempted the call from curl and Postman and got the same error message back. I checked the logs in Elastic Cloud as well, I don't see any errors in there.

I ended up opening a ticket. The issue was I was sending the request to Elasticsearch instead of Kibana, and using a POST request instead of a GET request. All sorted out now.