Upgrade elasticsearch version from 7.10 to 7.13 error

Hey guys, I am trying to update the version of elasticsearch to 7.13 from 7.10 and I am following the instructions from Rolling upgrades | Elasticsearch Guide [7.13] | Elastic but in the final when i procced with the instal I have this output:

// error: Failed dependencies:
        elasticsearch-oss conflicts with elasticsearch-0:7.13.0-1.x86_64
        elasticsearch conflicts with (installed) elasticsearch-oss-0:7.10.2-1.x86_64

If you know any other method beside uninstall 7.10 v. please help me.

Thx in advance.


can you state, which commands you used for upgrading? That might help to reproduce the issue.

Thank you!


1 Like

Also what OS and how you originally installed it would be helpful.

Hi Alex,
This are the steps I followed:

  1. Disable shard allocation .
  2. Stop non-essential indexing and perform a synced flush
  3. sudo systemctl stop elasticsearch.service
  4. rpm --import https://artifacts.elastic.co/GPG-KEY-elasticsearch
  5. sudo yum install --enablerepo=elasticsearch elasticsearch

and i tried also

Hi @warkolm ,

I use centos 7 and i installed elasticsearch from the rpm repo with yum


my RPM skills are a little rusty, but shouldnt one run the upgrade switch instead of the install switch when updating an existing RPM?

1 Like

I tried with some different methods but this gives one of the more accurate output:

sudo yum install --enablerepo=elasticsearch elasticsearch --skip-broken
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirrors.m247.ro
 * epel: fedora.mirrors.telekom.ro
 * extras: mirrors.nxthost.com
 * updates: mirrors.nxthost.com
Resolving Dependencies
--> Running transaction check
---> Package elasticsearch.x86_64 0:7.13.0-1 will be installed
--> Processing Conflict: elasticsearch-oss-7.10.2-1.x86_64 conflicts elasticsearch
--> Processing Conflict: elasticsearch-7.13.0-1.x86_64 conflicts elasticsearch-oss

Packages skipped because of dependency problems:
    elasticsearch-7.13.0-1.x86_64 from elasticsearch

that line was already hinted at above, but those two lines make it more clear.

You have the elasticsearch-oss distribution installed, but now you want to install the regular distribution. As the elasticsearch-oss package has a conflict configured for the elasticsearch package (and vice versa) to ensure that no two distributions are installed at the same time, you are getting this error message.

I suppose this requires deletion of the oss package and installation of the other. I remember that yum has a swap command, but I have never tested this - the most important part is to ensure that there is no deletion of configuration and data folders - so no purging of the package.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.