Upgrade from 2.4 to 5 Elasticsearch issues


(Michael Sully) #1

Used the upgrade plugin and sorted all issues, it flagged.
Then shutdown, single node cluster.
Upgraded using apt
Running Elasticsearch start then shuts down after about 12seconds
logs show see below, does not show any issues
But looking at journalctl --unit elasticsearch, i see the following

Oct 27 18:08:06 logstash-1 elasticsearch[915]: # LICENSE EXPIRED ON [Thursday, September 08, 2016]. IF YOU HAVE A NEW LICENSE, PLEASE
Oct 27 18:08:06 logstash-1 elasticsearch[915]: # UPDATE IT. OTHERWISE, PLEASE REACH OUT TO YOUR SUPPORT CONTACT.

This is strange as the cluster was working before the change and I can no longer see a license plugin and have no ability to install one.

Also note all I run with it is logstash and kibana, no services that are payed for.

It is like when I upgrade it installed an old free license, how do I go about upgrading it?

the following command gives me
/usr/share/elasticsearch/bin# ./elasticsearch-plugin install license
ERROR: Unknown plugin license

LOGS
[2016-11-10T12:36:21,769][INFO ][o.e.n.Node ] [node-1] initializing ...
[2016-11-10T12:36:21,974][INFO ][o.e.e.NodeEnvironment ] [node-1] using [1] data paths, mounts [[/ (/dev/sda6)]], net usable_space [1.7tb], net total_space [1.8tb], spins? [possibly], types [btrfs]
[2016-11-10T12:36:21,974][INFO ][o.e.e.NodeEnvironment ] [node-1] heap size [1.9gb], compressed ordinary object pointers [true]
[2016-11-10T12:36:21,981][INFO ][o.e.n.Node ] [node-1] version[5.0.0], pid[10836], build[253032b/2016-10-26T05:11:34.737Z], OS[Linux/4.2.0-42-generic/amd64], JVM[Oracle Corporation/Java HotSpot(TM) 64-Bit Server VM/1.8.0_45/25.45-b02]
[2016-11-10T12:36:24,177][INFO ][o.e.p.PluginsService ] [node-1] loaded module [aggs-matrix-stats]
[2016-11-10T12:36:24,177][INFO ][o.e.p.PluginsService ] [node-1] loaded module [ingest-common]
[2016-11-10T12:36:24,177][INFO ][o.e.p.PluginsService ] [node-1] loaded module [lang-expression]
[2016-11-10T12:36:24,178][INFO ][o.e.p.PluginsService ] [node-1] loaded module [lang-groovy]
[2016-11-10T12:36:24,178][INFO ][o.e.p.PluginsService ] [node-1] loaded module [lang-mustache]
[2016-11-10T12:36:24,178][INFO ][o.e.p.PluginsService ] [node-1] loaded module [lang-painless]
[2016-11-10T12:36:24,178][INFO ][o.e.p.PluginsService ] [node-1] loaded module [percolator]
[2016-11-10T12:36:24,178][INFO ][o.e.p.PluginsService ] [node-1] loaded module [reindex]
[2016-11-10T12:36:24,178][INFO ][o.e.p.PluginsService ] [node-1] loaded module [transport-netty3]
[2016-11-10T12:36:24,178][INFO ][o.e.p.PluginsService ] [node-1] loaded module [transport-netty4]
[2016-11-10T12:36:24,179][INFO ][o.e.p.PluginsService ] [node-1] no plugins loaded
[2016-11-10T12:36:28,464][INFO ][o.e.n.Node ] [node-1] initialized
[2016-11-10T12:36:28,465][INFO ][o.e.n.Node ] [node-1] starting ...
[2016-11-10T12:36:28,925][INFO ][o.e.t.TransportService ] [node-1] publish_address {REDACTED:9300}, bound_addresses {REDACTED:9300}
[2016-11-10T12:36:28,935][INFO ][o.e.b.BootstrapCheck ] [node-1] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks
[2016-11-10T12:36:28,940][ERROR][o.e.b.Bootstrap ] [node-1] node validation exception
bootstrap checks failed
max virtual memory areas vm.max_map_count [65530] likely too low, increase to at least [262144]
[2016-11-10T12:36:28,944][INFO ][o.e.n.Node ] [node-1] stopping ...
[2016-11-10T12:36:29,014][INFO ][o.e.n.Node ] [node-1] stopped
[2016-11-10T12:36:29,015][INFO ][o.e.n.Node ] [node-1] closing ...
[2016-11-10T12:36:29,042][INFO ][o.e.n.Node ] [node-1] closed


(Michael Sully) #2

OK, I have now got it up and running.

Had to change a couple of things, but most notably, is that it would not work with an external IP, as soon as I set this to local, it worked. This was the main reason it was shutting itself down. The licence issue was because I had trialled watcher in the past and it had not fully removed itself.

So my question has changed, how do I get an external IP back onto elastic search, as I make changes on the server during my testing remotely using Sense.


(Christian Dahlqvist) #3

You may want to read this blog post about the bootstrap checks in Elasticsearch 5.0.


(Michael Sully) #4

Thanks for that, it does explain what happening and why they are doing it, but that is all. Not the most helpful for getting it setup.


(Christian Dahlqvist) #5

It does link to the list of checks that are performed in the documentation so that you can go through and make sure they are all covered.


(Michael Sully) #6

Thanks, had just stumbled across that myself, after you lead me in the right direction.
Cheers, think I know what I need to do.


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.