Upgrade Java for Elasticsearch and logstash

Hi,

Can anyone let me know how I can upgrade the java JDK on Elasticsearch and logstash.

 Path : /usr/share/logstash/jdk/
  Installed version : 11.0.14.1 2022-02-08
  Upgrade to a version greater than 11.0.16
Path : /usr/share/elasticsearch/jdk/
  Installed version : 17.0.2 2022-01-18
  Upgrade to a version greater than 17.0.4

Thanks

Hi,
Can anyone help me to resolve this ?

Regards,
Ravi

Are you using the bundled one, or one you have installed?

Hi Warkolm,

Thanks for the reply..
We have installed ELK on RHEL 8.

Regards,
Ravi

Hi,

Can anyone help me to setup this ?

Regards,
Ravi

This is important. What JVM are you using?

Hi Warkolm,

Yes we have Installed version : 11.0.14.1 2022-02-08 it's not bundled one.

Thanks,
Regards,
Ravi

Then you should upgrade it depending on your OS instructions, just make sure you go to a version that matches Support Matrix | Elastic