Upgraded ES from 6.8.10 to 7.7...now Kibana has no such index for _xpack

Pretty much as the title says.
We upgraded our ElasticSearch install to run 7.7. That seems to have worked fine, but, Kibana no longer works with this error:

{"statusCode":404,"error":"Not Found","message":"[index_not_found_exception] no such index [_xpack], with { resource.type=\"index_expression\" & resource.id=\"_xpack\" & index_uuid=\"_na_\" & index=\"_xpack\" }"}

How can this be fixed? Why did the upgrade cause this?

We follow this guide: https://www.elastic.co/guide/en/elasticsearch/reference/current/rolling-upgrades.html
The only thing I can see is this line, which has no other information (making the guide questionable in my opinion):
" Use the elasticsearch-plugin script to install the upgraded version of each installed Elasticsearch plugin. All plugins must be upgraded when you upgrade a node."

If I run

/usr/share/elasticsearch/bin/elasticsearch-plugin list

We get nothing back, so I assume we have no plugins installed.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.