URL Links from Index Patterns Redirect to Port 5601

Good morning!

We just recently spun up a second Kibana instance and threw both behind a load-balancer for HA. We previously accessed Kibana via https://kb1.contoso.com:5601, but now with the second server of https://kb2.contoso.com:5601, the idea is to access Kibana simply via https://kb.contoso.com with the port redirected/masked. Unfortunately, this seems to have broken any URLs that are specified in Index Patterns (does not appear to affect URLs in MarkDown visualizations).

We have many fields in Index Patterns that are set to URL formats that take you to specific places in Kibana. For instance, host.name is a URL to a dashboard with details on the host. The exact URL template I have specified for host.name in one Index Pattern is ./dashboards#/view/bba48ba0-912d-61na-9b02-331q73beaf05?_a=(query:(language:kuery,query:'host.name:"{{value}}"')) and the value of Label template is {{value}}. This used to work perfectly fine, but now behind the load-balancers, clicking the URL generated by this automatically appends the port :5601 to the URL, but the load-balancer is not accepting the URL with the port specified.

I am working with my networking team to see if there is something they can do on their end to either allow port 5601, or to strip the port off any requests, but I am also curious as to why Kibana seems to be doing this on Index Pattern URLs, but not MarkDown URLs when they are both defined with the same relative URL.

Would appreciate any feedback on this!

Thank you,
Eric

Hello @MakoWish

I'm aware that the behavior of url generation relating to field formatters is sub optimal but I haven't had a chance to dig into this particular problem. Generally speaking, how many url formatters are used? Could you try opening one and making a small modification to see if it fixes the url? I suspect that the port number is saved when the formatter is created or updated which is unhelpful when its no longer accessed through that port.

Thanks,
Matt

Hi Matt,

Thank you for the reply! Based on your information, it appears updating the URL formatter does not resolve the issue, but removing and adding it back does. I had already tried modifying and saving the URL formatter, but that did not fix it. After seeing your response, I just tried setting one field back to Default, then changing it to URL again. The URL no longer has the port specified, so we are golden!

Unfortunately, I do have roughly 50 fields using URL formatters, so it will be a bit of a pain to remove and add them all back, but at least there is a workaround!

Thank you again, Matt!

Eric