URL path in Index pattern > Edit path is not working for server file link

Hi,
I tried to give a file path as url link in Index pattern > Edit path field.
The file located in a server location.
In order to open a file in a browser, it should have a prefix "File://". I tried to give this but something is not correct.
I tried two combination of prefix as mentioned in the pictures. You can see that when i give "http://file://" the generated link misses ":" and this leads to unresolved location.
if i give only "file://" it adds local pc information as well which is not necessary.

Please advise me on how to come out of this problem.
Let me know if you need additional details.
Kibana : 7.7.0

Hi @esaravanan85 sorry for the late reply, have you found a solution?
I've quickly take a look at your problem and from a security stand point I don't think it's possible to have links that can open any file on your FS. Kibana cannot serve these file from the browser

Hi Mark,
I found alternate local server path to link the files and that is working fine.
But i'm still not convinced with the way kibana works for the scenario #1 i mentioned. Why it is ignoring the ":" as highlighted?
Will it violate security settings ? Please comment.
Thanks

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.