Vega Visualizations in Kibana: 400 error setting default pattern

Class/lab has me create index patterns; which works fine. I cannot proceed to the next step of going to Discover w/o setting a default pattern. When I click the start, for either pattern, a 400 error is throw w/an exception. I've also tried manually setting in advanced settings and dev tools to the .kibana index w/o success.

This thread had the exact issue but was auto-closed. Please assist.

Hi @jonahzirkle! Can you try deleting the .kibana index?

To do this:

  • Go to Dev Tools on the left panel.
  • Copy-paste this: DELETE .kibana then click the Apply button (sideways triangle)

Now go back to Management>Index Pattern and try to create the two index patterns again.

1 Like

Hi @jonahzirkle

Before deleting the .kibana-index I would try a different approach.

  1. Create the index pattern
  2. Set it as default index pattern
  3. Refresh your browser

I'm not sure what exact problem you are facing, but often index-pattern-related issues are caused by caching issue in web browsers.

Let me know whether that helped.

Cheers, Daniel

This took care of it. Thank you!

  1. Step 1 was fine.
  2. Would not auto set or allow me to set as default. Thus the 400 error.
  3. Refreshed, deleted patterns and tried again. Ingested other data and tried on that and same result.

The fix ended up being to delete .kibana and start over. It immediately assigned the first pattern as the default.

Appreciate your time and input.