6.1.1 - Default Index-Pattern not set, and existing patterns are not visible


(Karthik Ramachandran) #1

Background:

Installed Kibana, and able to browse the UI
Created Index-Pattern from Management area (UI), and ensure that it is persisted in ".kibana" indice
Made the index-pattern default (by clicking icon on top right)
Tried the same many times with different values - and observed ".kibana" indice added with patterns

Problem:

Even after creating the patterns, none of them were visible back in kibana, though it is present in indice ".kibana"
No pattern is set as default pattern

Logs Observed
(NOTE: Not all entires are provided below, but APIs that could represent the actions were referenced with 200 response)

respons [01:05:48.525] POST /api/kibana/settings/defaultIndex 200 773ms - 9.0B
respons [01:05:03.782] GET /api/saved_objects/?type=index-pattern&per_page=10&search=%22search*%22&search_fields=title&fields=title&page=1 200 39ms - 9.0B
respons [01:05:03.838] POST /api/saved_objects/index-pattern?overwrite=false 200 427ms - 9.0B
respons [01:18:31.316] GET /api/saved_objects/?type=index-pattern&fields=title&per_page=10000&page=1 200 30ms - 9.0B
respons [01:18:31.379] GET /api/saved_objects/?type=index-pattern&fields=title&per_page=10000&page=1 200 10ms - 9.0B

Stuck with kibana not usable. Any help is appreciated.

Regards
KarthiK


(Marius Dragomir) #2

Hello, what version of Kibana are you using?


(Karthik Ramachandran) #3

Kibana 6.1


(kulkarni) #4

When you create the index pattern in KB, make sure you set the timestamp field to be the one in the document. Also if you have already done that ( if its a time based data) did you set the exact time interval in which the data is present ? You can do so in Discover > right hand corner- select the time range.

Check these steps and let us know

Thanks
Rashmi


(Karthik Ramachandran) #5

hi rashmi,

Timestamp field is set.

WHen I create the index pattern, the first step is that I chose the same. When I click next, I see the attributes of the indices that match the pattern as well.

I also validate that kibana stores it in elastic .kibana metadata. But What is not stored is - the default staus of the pattern. Also, the kibana is not listing all the patterns saved in .kibana indice.

I have saved atleast 20 indice patterns now :-). Strange factor is it is able to save, but not able to read and list from .kibana indice. Also, it cannot set a pattern as default.


(Lee Drengenberg) #6

It sounds like you're already looking at this but could you post the response to this;

GET .kibana/_search
{
  "query": {
    "bool": {
      "should": [
        {
          "match_phrase": {
            "type": "config"
          }
        }
      ],
      "minimum_should_match": 1
    }
  }
}

I think I have seen this before but don't know what caused it. I think in the past I deleted the .kibana index and then things worked after that. Of course you wouldn't want to do this if you have other saved objects already set up in your Kibana.

I'd like to see that your _id matches your version and if everything else looks OK.


(Karthik Ramachandran) #7

Reinstalled all to get rid of the issue, but couldn't able to find the root cause :frowning:


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.