Visualisations not working following upgrade to Kibana 7.2 - illegal_argument_exception] [filters] cannot be empty

Hi,

Today we upgraded two of our ElasticSearch clusters to Kibana 7.2.0 from version 7.1.1.

In both clusters some of our Kibana visualisations have now stopped working. Looking in syslog, Kibana is producing errors along the lines of:

error":{"message":"[illegal_argument_exception] [filters] cannot be empty."

An example visualisation where this occurs is for a table with three sub buckets associated to a search which happens to produce no results. It would appear that if the first sub bucket produces no results, subsequent sub buckets cause the error above.

Is this a bug?

1 Like

Just to add, I tried down grading Elastic Search and Kibana to 7.1.1 but then Elastic Search fails to start.

I'm facing the exact same issue since upgrading to 7.2.0
After some investigation it looks like related to missing ' characters in the id= parameter of the (embeddableConfig:()

this works:
http://localhost:5601/app/kibana#/dashboard/f7a863d0-2dd6-11e9-8416-e5594c151510?_g=(refreshInterval:(pause:!t,value:0),time:(from:now-7d,to:now))&_a=(description:'',filters:!(),fullScreenMode:!f,options:(darkTheme:!f,hidePanelTitles:!t,useMargins:!t),panels:!((embeddableConfig:(),gridData:(h:22,i:'1',w:24,x:0,y:0),id:'0692dc50-2dd6-11e9-8416-e5594c151510',panelIndex:'1',type:visualization,version:'6.6.0'),(embeddableConfig:(),gridData:(h:11,i:'2',w:14,x:34,y:0),id:'51808820-2dd6-11e9-8416-e5594c151510',panelIndex:'2',type:visualization,version:'6.6.0'),(embeddableConfig:(),gridData:(h:11,i:'3',w:14,x:34,y:11),id:'8c197280-2dd6-11e9-8416-e5594c151510',panelIndex:'3',type:visualization,version:'6.6.0'),(embeddableConfig:(),gridData:(h:30,i:'4',w:48,x:0,y:22),id:c5f51cd0-2dd5-11e9-8416-e5594c151510,panelIndex:'4',type:search,version:'6.6.0'),(embeddableConfig:(),gridData:(h:4,i:'5',w:10,x:24,y:0),id:'2e741990-2dd7-11e9-8416-e5594c151510',panelIndex:'5',type:visualization,version:'6.6.0'),(embeddableConfig:(),gridData:(h:9,i:'6',w:10,x:24,y:4),id:'3f138320-2dd8-11e9-8416-e5594c151510',panelIndex:'6',type:visualization,version:'6.6.0'),(embeddableConfig:(),gridData:(h:9,i:'7',w:10,x:24,y:13),id:'0a6fb670-2dd8-11e9-8416-e5594c151510',panelIndex:'7',type:visualization,version:'6.6.0')),query:(language:lucene,query:''),timeRestore:!f,title:EntityAuditLog,viewMode:view)

does not work:
http://localhost:5601/app/kibana#/dashboard/5fba3a10-1893-11e9-a8fc-b99321995eaa?_g=(refreshInterval:(pause:!t,value:0),time:(from:now-7d,to:now))&_a=(description:'',filters:!(),fullScreenMode:!f,options:(darkTheme:!f,hidePanelTitles:!t,useMargins:!f),panels:!((embeddableConfig:(),gridData:(h:8,i:'2',w:11,x:37,y:0),id:'54cddc20-1892-11e9-a8fc-b99321995eaa',panelIndex:'2',type:visualization,version:'6.5.4'),(embeddableConfig:(),gridData:(h:13,i:'3',w:18,x:0,y:16),id:'8a72c520-1892-11e9-a8fc-b99321995eaa',panelIndex:'3',type:visualization,version:'6.5.4'),(embeddableConfig:(),gridData:(h:16,i:'4',w:10,x:27,y:0),id:b72e7dc0-1892-11e9-a8fc-b99321995eaa,panelIndex:'4',type:visualization,version:'6.5.4'),(embeddableConfig:(),gridData:(h:13,i:'5',w:17,x:18,y:16),id:'437c75c0-1893-11e9-a8fc-b99321995eaa',panelIndex:'5',type:visualization,version:'6.5.4'),(embeddableConfig:(),gridData:(h:44,i:'6',w:48,x:0,y:29),id:d1f59d10-1891-11e9-a8fc-b99321995eaa,panelIndex:'6',type:search,version:'6.5.4'),(embeddableConfig:(),gridData:(h:16,i:'7',w:27,x:0,y:0),id:'8269bca0-1ca5-11e9-a331-11a5b34ebba4',panelIndex:'7',type:visualization,version:'6.5.4'),(embeddableConfig:(),gridData:(h:8,i:'8',w:11,x:37,y:8),id:a7d50180-1d4e-11e9-a331-11a5b34ebba4,panelIndex:'8',type:visualization,version:'6.5.4'),(embeddableConfig:(),gridData:(h:13,i:'9',w:13,x:35,y:16),id:'3e919bf0-1d50-11e9-a331-11a5b34ebba4',panelIndex:'9',type:visualization,version:'6.5.4')),query:(language:lucene,query:''),timeRestore:!f,title:'Log%20-%20Wm6RollingFileAppender',viewMode:view)

Works: Adapted the link that did not work by adding ' characters to the id parameters:
http://localhost:5601/app/kibana#/dashboard/5fba3a10-1893-11e9-a8fc-b99321995eaa?_g=(refreshInterval:(pause:!t,value:0),time:(from:now-7d,to:now))&_a=(description:'',filters:!(),fullScreenMode:!f,options:(darkTheme:!f,hidePanelTitles:!t,useMargins:!f),panels:!((embeddableConfig:(),gridData:(h:8,i:'2',w:11,x:37,y:0),id:'54cddc20-1892-11e9-a8fc-b99321995eaa',panelIndex:'2',type:visualization,version:'6.5.4'),(embeddableConfig:(),gridData:(h:13,i:'3',w:18,x:0,y:16),id:'8a72c520-1892-11e9-a8fc-b99321995eaa',panelIndex:'3',type:visualization,version:'6.5.4'),(embeddableConfig:(),gridData:(h:16,i:'4',w:10,x:27,y:0),id:'b72e7dc0-1892-11e9-a8fc-b99321995eaa',panelIndex:'4',type:visualization,version:'6.5.4'),(embeddableConfig:(),gridData:(h:13,i:'5',w:17,x:18,y:16),id:'437c75c0-1893-11e9-a8fc-b99321995eaa',panelIndex:'5',type:visualization,version:'6.5.4'),(embeddableConfig:(),gridData:(h:44,i:'6',w:48,x:0,y:29),id:'d1f59d10-1891-11e9-a8fc-b99321995eaa',panelIndex:'6',type:search,version:'6.5.4'),(embeddableConfig:(),gridData:(h:16,i:'7',w:27,x:0,y:0),id:'8269bca0-1ca5-11e9-a331-11a5b34ebba4',panelIndex:'7',type:visualization,version:'6.5.4'),(embeddableConfig:(),gridData:(h:8,i:'8',w:11,x:37,y:8),id:'a7d50180-1d4e-11e9-a331-11a5b34ebba4',panelIndex:'8',type:visualization,version:'6.5.4'),(embeddableConfig:(),gridData:(h:13,i:'9',w:13,x:35,y:16),id:'3e919bf0-1d50-11e9-a331-11a5b34ebba4',panelIndex:'9',type:visualization,version:'6.5.4')),query:(language:lucene,query:''),timeRestore:!f,title:'Log%20-%20Wm6RollingFileAppender',viewMode:view)

@patrikjetzer glad to hear that I'm not the only one suffering this issue.

I did try your suggestion with our set-up but the errors remain.

The only way I can get the errors to stop is to increase the time range on the dashboard or visualisation so that the underlying search returns a result.

I've now tracked down the issue...

  1. Create a search that returns no results for a given data set / time range.

  2. Create a visualisation (e.g. a bar chart) linked to the search.

  3. Add a time series to the X axis.

  4. Add a split series and enable the "Group other values in separate bucket".

The visualisation will now fail to work. Disabling the "Group other values in separate bucket" will make the visualisation operate correctly and report no results.

An issue for this bug has been created on Github and is being investigated: https://github.com/elastic/kibana/issues/39654

Wanted to post a link here just in case folks stumbling upon this thread wanted to follow along as we work to get it fixed.

@lukeelmers thank you for the update, hope the bug gets fixed soon.