Visualize: "field" is a required parameter?


(aabababba) #1

help?


(Guillaume Dufrenne) #2

it happens when your index has changed and the field concerned doesn't exist anymore in your documents.
So , the visualization can't find it .

Or maybe this field wasn't marked as aggregatable or searchable in the index pattern menu

Maybe try to refresh the index pattern ...


(aabababba) #3

how to refresh the index pattern?


(aabababba) #4

No data to display for the selected metrics?
any idea?。。。


(aabababba) #5

[indices:data/read/search[phase/query]]
Caused by: java.lang.IllegalArgumentException: Fielddata is disabled on text fields by default. Set fielddata=true on [beat.name] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead.


(Guillaume Dufrenne) #6

Management> Index pattern

Go to top right and corner
image


(aabababba) #7

I get it.but now the error is

[indices:data/read/search[phase/query]]
Caused by: java.lang.IllegalArgumentException: Fielddata is disabled on text fields by default. Set fielddata=true on [beat.name] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead.

I should set this every day?

   PUT metricbeat-*/_mapping/doc?update_all_types
{
  "properties": {
    "beat.name": {
      "type": "text",
     "fielddata": true
    }
  }
}

(aabababba) #8
{
  "error": {
    "root_cause": [
      {
        "type": "illegal_argument_exception",
        "reason": "mapper [system.network.name] of different type, current_type [keyword], merged_type [text]"
      }
    ],
    "type": "illegal_argument_exception",
    "reason": "mapper [system.network.name] of different type, current_type [keyword], merged_type [text]"
  },
  "status": 400
}

now the error is this。。。


(aabababba) #9

anybody can help this?。。。


(system) #10

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.