Watcher PDF reporting fails on dockerised 7.17.x

Since my ELK stack upate from 7.16.2 to 7.17.1 (and 7.17.2 after that) Watcher has been unable to generate PDF reports. I run a dockerised ELK on Amazon EC2- using the Elastic-provided docker images.

When I went to look today what what going on, I found a few dozen core files in /usr/share/kibana.

When I run ./x-pack/plugins/reporting/chromium/headless_shell-linux_arm64/headless_shell manually, a core dump is indeed generated, with the trace:

kibana@kibana:~$  ./x-pack/plugins/reporting/chromium/headless_shell-linux_arm64/headless_shell 
[0405/012747.320882:WARNING:resource_bundle.cc(403)] locale_file_path.empty() for locale 
[0405/012747.321209:FATAL:zygote_host_impl_linux.cc(117)] No usable sandbox! Update your kernel or see https://chromium.googlesource.com/chromium/src/+/main/docs/linux/suid_sandbox_development.md for more information on developing with the SUID sandbox. If you want to live dangerously and need an immediate workaround, you can try using --no-sandbox.
#0 0xaaaab0739030 base::debug::CollectStackTrace()
#1 0xaaaab06bb6e4 base::debug::StackTrace::StackTrace()
#2 0xaaaab06cba38 logging::LogMessage::~LogMessage()
#3 0xaaaaaf84f684 content::ZygoteHostImpl::Init()
#4 0xaaaaaf9b2bdc content::ContentMainRunnerImpl::Initialize()
#5 0xaaaaaf9b1440 content::RunContentProcess()
#6 0xaaaaaf9b1554 content::ContentMain()
#7 0xaaaab06b5ac0 headless::HeadlessBrowserMain()
#8 0xaaaab06b5830 headless::HeadlessShellMain()
#9 0xffffa0d22d50 __libc_start_main
#10 0xaaaaae6c89f4 (/usr/share/kibana/x-pack/plugins/reporting/chromium/headless_shell-linux_arm64/headless_shell+0x2aee9f3)

Received signal 6
#0 0xaaaab0739030 base::debug::CollectStackTrace()
#1 0xaaaab06bb6e4 base::debug::StackTrace::StackTrace()
#2 0xaaaab0738fb8 base::debug::(anonymous namespace)::StackDumpSignalHandler()
#3 0xffffa11bf668 ([vdso]+0x667)
#4 0xffffa0d35cd8 gsignal
#5 0xffffa0d22a28 abort
#6 0xaaaab07383e0 base::debug::BreakDebugger()
#7 0xaaaab06cbe20 logging::LogMessage::~LogMessage()
#8 0xaaaaaf84f684 content::ZygoteHostImpl::Init()
#9 0xaaaaaf9b2bdc content::ContentMainRunnerImpl::Initialize()
#10 0xaaaaaf9b1440 content::RunContentProcess()
#11 0xaaaaaf9b1554 content::ContentMain()
#12 0xaaaab06b5ac0 headless::HeadlessBrowserMain()
#13 0xaaaab06b5830 headless::HeadlessShellMain()
#14 0xffffa0d22d50 __libc_start_main
#15 0xaaaaae6c89f4 (/usr/share/kibana/x-pack/plugins/reporting/chromium/headless_shell-linux_arm64/headless_shell+0x2aee9f3)
[end of stack trace]
Aborted (core dumped)

I am able to avoid that core dump of I add the --no-sandbox parameter. How do I ensure Kibana uses that same parameter internally?

Update: RTFM: xpack.reporting.capture.browser.chromium.disableSandbox. However, having set that to true all I get now is no more core dumps; also still no PDFs in my inbox :-/

Update update: Patience, grasshopper. I have mails now, with the expected PDFs attached. Thanks!

Glad you got it sorted. copying @tsullivan for information .