Where to find saved visualization for Events Received Rate (/s) for Logstash?

(Amit Hora) #1

I want to modify already available logstash moitor UI with kibana and x-pack. But i can not find definitions for the available visualizations.

Would be great if someone could help

(Shaunak Kashyap) #2

Hi, the visualizations you see in the Monitoring UI are not saved in Kibana like other visualizations created by you. So they cannot be modified. This might change in the future but today they are only available as part of the Monitoring UI.


(Amit Hora) #3

Can you tell me where i can find query that calculates this Events per sec. As i can see in Nodes stats API i only have Events.in , events.duration_in_millis field.
I am confused on how to calculate event in per second using data in .monitoring-logstash index

(Shaunak Kashyap) #4

I'll be happy to share the query with you but first let me just show you how to create the chart you want using the Time Series Visual Builder.

  1. Open the Visualize app in Kibana (2nd icon from top in left nav).

  2. Click on the Create a visualization button.

  3. Choose Visual Builder under Time Series.

  4. Set your series label to "Events Rate /s"".

  5. Click on the Panel Options tab and make sure the Index Pattern is set to ".monitoring-logstash-*" and the Time Field is set to "logstash_stats.timestamp"

  6. Click on the Data tab.

  7. Change the Aggregation from "Count" to "Max". Set the Field to "logstash_stats.events.out"

  8. Click the small + icon in the same row on the right. This should load up another Aggregation row .

  9. In the 2nd aggregation row, change the Aggregation from "Count" to "Derivative". Set the Metric to "Max of logstash_stats.events_out" and Units to "1s".

  10. This will give you a visualization for "Events Rate /s". See the screenshots below in case these text instructions are not clear.

Panel Options tab

Data tab

(Amit Hora) #5

Thanks for the help!

(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.