Where to get marvel 1.3

monitoring

(Lifo888) #1

Hi,
Anybody know where i can get the binary for marvel 1.3 as well as license plugin that's compatible with that version?

Thanks,
GC


(Mark Walkom) #2

Does https://www.elastic.co/guide/en/marvel/1.3/installation.html help?


(TW) #3

The command bin/plugin install --verbose elasticsearch/marvel/latest is returning a FileNotFoundException


(Mark Walkom) #4

Can we see the complete command from the console?


(TW) #5

Yep,

-> Installing elasticsearch/marvel/latest...
Trying https://download.elastic.co/elasticsearch/marvel/marvel-latest.zip ...
Failed: FileNotFoundException[https://download.elastic.co/elasticsearch/marvel/marvel-latest.zip]; nested: FileNotFoundException[https://download.elastic.co/elasticsearch/marvel/marvel-latest.zip];
Trying https://search.maven.org/remotecontent?filepath=elasticsearch/marvel/latest/marvel-latest.zip ...
Failed: FileNotFoundException[https://search.maven.org/remotecontent?filepath=elasticsearch/marvel/latest/marvel-latest.zip]; nested: FileNotFoundException[https://search.maven.org/remotecontent?filepath=elasticsearch/marvel/latest/marvel-latest.zip];
Trying https://oss.sonatype.org/service/local/repositories/releases/content/elasticsearch/marvel/latest/marvel-latest.zip ...
Failed: FileNotFoundException[https://oss.sonatype.org/service/local/repositories/releases/content/elasticsearch/marvel/latest/marvel-latest.zip]; nested: FileNotFoundException[https://oss.sonatype.org/service/local/repositories/releases/content/elasticsearch/marvel/latest/marvel-latest.zip];
Trying https://github.com/elasticsearch/marvel/archive/latest.zip ...
Failed: FileNotFoundException[https://github.com/elasticsearch/marvel/archive/latest.zip]; nested: FileNotFoundException[https://github.com/elasticsearch/marvel/archive/latest.zip];
Trying https://github.com/elasticsearch/marvel/archive/master.zip ...
Failed: FileNotFoundException[https://github.com/elasticsearch/marvel/archive/master.zip]; nested: FileNotFoundException[https://github.com/elasticsearch/marvel/archive/master.zip];
ERROR: failed to download out of all possible locations..., use --verbose to get detailed information


(Mark Walkom) #6

What about the bin/plugin blah blah blah part? :slight_smile:


(TW) #7

Posted that earlier: bin/plugin install elasticsearch/marvel/latest


(Mark Walkom) #8

ES 1.7.3, Marvel 1.3.
Worked fine for me.

# /usr/share/elasticsearch/bin/plugin install elasticsearch/marvel/latest
-> Installing elasticsearch/marvel/latest...
Trying http://download.elasticsearch.org/elasticsearch/marvel/marvel-latest.zip...
Downloading ..........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................DONE
Installed elasticsearch/marvel/latest into /usr/share/elasticsearch/plugins/marvel

Installing Marvel 2.1 issue
(TW) #9

I see, there are different versions of Marvel for ES 1.0 - 1.7 and for 2.1. I have ES 2.1. I'm following the Intro video, which uses an older version of ES.


(Mark Walkom) #10

You cannot Marvel use 1.3 with ES 2.X. You need to use Marvel 2.X, where X is the same minor version as the ES one.


(system) #11