While indexing a document into elasticsearch, I am getting " "message": "Payload content length greater than maximum allowed: 1048576"


(Jason Smith) #1

Hello folks,

Newbie to ELK.

I have downloaded shakespeare.json file from elastic.co site to practice Queries from Kibana console. when I try to index the JSON document using the following request, I get the following error.

         {
                "statusCode": 400,
                "error": "Bad Request",
                "message": "Payload content length greater than maximum allowed: 1048576"
        }

Any suggestions please?
Thank You


(Jon Budzenski) #2

Kibana has a configured upload limitation of 1mb by default. You can bump it up in kibana.yml by setting server.maxPayloadBytes: _some_number > 1048576


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.