公式コンテナイメージを使用した際のX-Packの無効化について


#1

お世話になります。

Elasticの公式レジストリ(docker.elastic.co/elasticsearch/elasticsearch:5.4.0)を使用してElasticsearchを起動してます。
X-Packを全て無効化したいと考えているのですが、
この場合docker run時に与える環境変数は"xpack.security.enabled=false"だけで良いのでしょうか?

X-Packの各パッケージの設定ドキュメントの最初に xpack.xxx.enabledの記載があったので、
これらの設定もすべて渡しているのですがプロセスが落ちてしまう状況です。
"xpack.security.enabled=false"だけ渡した状態だと起動してくれます。

参考までに、私がdocker-composeで渡している環境変数の一覧を以下に記載します。

    environment:
      - "http.host=0.0.0.0"
      - "transport.host=127.0.0.1"
      - "xpack.security.enabled=false"
      - "xpack.monitoring.enabled=false"
      - "xpack.watcher.enabled=false"
      - "xpack.reporting.enabled=false"
      - "xpack.graph.enabled=false"
      - "xpack.ml.enabled=false"
      - "ES_JAVA_OPTS=-Xms512m -Xmx512m"

#2

自己解決しました。。。
xpack.reporting.enabledはElasticsearchにはない(kibana.ymlだけの)パラメータでした。


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.