A node cannot be upgraded directly from version [7.10.2] to version [8.4.3], it must first be upgraded to version [7.17.0]

Hi Team,

I'm not sure how elastic verion managed to upgrade the major version without tried anyone. Did the stack try to upgrade itself?

Kindly help how can i fix this error. my kibana down due to this error

Elasticsearch cannot upgrade itself, so if the package has upgraded then something has done that.

@warkolm and Team,

Kindly help how to troubleshoot and fix this. i will provide required information.


Kibana url not reachable.
I have tried to debug issue as below.

first i have downgraded elasticsearch to 7.17.0 version and kibana still showing 8.4.3 version.

kibana service keep on failing.

kibana logs

root@elk:/etc/elasticsearch# sudo journalctl -fu kibana.service
-- Logs begin at Tue 2022-10-11 09:15:11 IST. --
Oct 20 00:22:16 elk kibana[622019]: at bootstrap (/usr/share/kibana/src/core/server/bootstrap.js:99:9)
Oct 20 00:22:16 elk kibana[622019]: at Command. (/usr/share/kibana/src/cli/serve/serve.js:216:5)
t 20 00:22:16 elk kibana[622019]: FATAL Error: [config validation of [elasticsearch].username]: value of "elastic" is forbidden. This is a superuser account that cannot write to system indices that Kibana needs to function. Use a service account token instead. Learn more: Service accounts | Elasticsearch Guide [8.0] | Elastic
Oct 20 00:22:16 elk systemd[1]: kibana.service: Main process exited, code=exited, status=78/CONFIG

ufu status : inactive

in server below Ports opened . in below 5601 port not opened

root@elk:/etc/elasticsearch# netstat -tulpn | grep LISTEN

tcp 0 0* LISTEN 632/systemd-resolve
tcp 0 0* LISTEN 846/sshd: /usr/sbin
tcp6 0 0 :::9200 :::* LISTEN 623594/java
tcp6 0 0 :::9300 :::* LISTEN 623594/java
tcp6 0 0 :::22 :::* LISTEN 846/sshd: /usr/sbin

Elastic search logs

[2022-10-20T08:18:10,086][INFO ][o.e.x.i.IndexLifecycleRunner] [node-1] policy [apm-rollover-30-days] for index [apm-7.10.2-span] on an error step due to a transient error, moving back to the failed step [check-rollover-ready] for execution. retry attempt [227]

[2022-10-20T08:18:10,087][ERROR][o.e.x.i.IndexLifecycleRunner] [node-1] policy [apm-rollover-30-days] for index [apm-7.10.2-metric] failed on step [{"phase":"hot","action":"rollover","name":"check-rollover-ready"}]. Moving to ERROR step

kibana.ym file below things uncommented.

kindly review the kibana.yml file below and help me to fix. Elastic is the user name I use. It was working fine for me.

server.port: 5601
server.host: ""
server.name: "elk-server"
elasticsearch.hosts: ["http://localhost:9200"]
elasticsearch.username: "elastic"
elasticsearch.password: "RTMRpVBdtJwPhHR9"


Did you follow the link that the error provides - Service accounts | Elasticsearch Guide [8.0] | Elastic?

Sure @warkolm i will check

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.