Are the following plugins (attachment, geoip, user-agent) for ingest node already been shipped with ES 5.4.0?


(Girirajsharma) #1

Are the following plugins (attachment, geoip, user-agent) for ingest node already been shipped with ES 5.4.0 ? If not, what is the expected ES 5.5.0 release date ?

Refer:
[1]https://www.elastic.co/guide/en/elasticsearch/plugins/5.x/ingest.html
[2]https://www.elastic.co/guide/en/elasticsearch/plugins/5.x/ingest-attachment.html

The Installation Section in [2] says:

Installation
Version 5.5.0 of the Elastic Stack has not yet been released.

On the contrary, ES 5.4.0 changeLog has reference to Ingest Attachment.

Plugin Ingest Attachment
Remove support for Visio and potm files #23214 (issues: #22077, #22079, #22963)

(David Pilato) #2

Those plugins are available for 5.4.0. What do you mean?


(Girirajsharma) #3

@dadoonet Please check the link https://www.elastic.co/guide/en/elasticsearch/plugins/5.x/ingest-attachment.html. Here, it is mentioned in the installation steps -

Installation
Version 5.5.0 of the Elastic Stack has not yet been released.

So, I suppose that these plugins are not available as per now and will only be available with the release of Version 5.5.0.


(David Pilato) #4

But why are you looking at a documentation of a product which has not been released? (5.x).

There is a big yellow rectangle on top of this page asking you to go to the released version which is https://www.elastic.co/guide/en/elasticsearch/plugins/current/ingest-attachment.html


(Girirajsharma) #5

@dadoonet Apologies, my bad. I was so much lost in the content that couldn't realise the big yellow rectangle.


(David Pilato) #6

No need to apologize. Glad you found it.


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.