Auto discovery of unique values when creating filters kills performance


(Simon) #1

Attempting to manually create a filter in a visualisation by selecting the "attribute" -> "is one of" -> "value" causes an astonishing loss of performance within our ES cluster. I've narrowed this down to the auto discovery of values for the drop-down - as soon as this is invoked, the searching goes wild for a time and no other visualisations work.

Searching in general is otherwise OK, and visualisations that already have filters don't cause this issue, and we can add filters "automatically" (i.e. by clicking on some part of another visualisation or the legend) and the problem doesn't appear, so it seems to be the auto discovery process.

Of course I'd love to find out how to get this to work, but in the meantime is there any way to disable this so that Kibana doesn't even bother to try to find the unique values? It isn't necessary for us and Kibana allows you to enter any value anyway.

We're maintaining daily indices for our application with about 50GB of data per day with a large number of small documents (i.e. event logs). We don't have many fields, although some have a lot of potential values. We see this issue even on fields that have only a small number of unique values (less than 10) and when the visualisation time range is just 15 mins.

Any help gratefully received!


(Lukas Olson) #2

What version of Kibana are you using?

You can disable this feature by going into the advanced settings and setting filterEditor:suggestValues to false. We've made improvements to this feature in the 6.0 preview releases, if you'd like to take a look.


(Simon) #3

Thank you for the reply Lukas. We're using v 5.5.0 but I can't see this
configuration option in the advanced settings. Is this only available in a
later version?


(Lukas Olson) #4

Yeah, the setting was actually added in 5.5.1 I believe.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.