Beta-1 packages in yum repository are not signed?


(Shin Tanimoto) #1

Hi,
I tried to install Elasticsearch / Kibana / Beats on Amazon Linux by yum command following the document.
https://www.elastic.co/guide/en/beats/libbeat/master/setup-repositories.html

But I could not finish yum command with this error message.
Package packetbeat-5.0.0-beta1-x86_64.rpm is not signed

When I modified the .repo file changing gpgcheck from 1 to 0, I could finish installing.

installation detail is as follows.

$ sudo yum install packetbeat -y
Loaded plugins: priorities, update-motd, upgrade-helper
amzn-main/latest                                         | 2.1 kB     00:00
amzn-updates/latest                                      | 2.3 kB     00:00
Resolving Dependencies
--> Running transaction check
---> Package packetbeat.x86_64 0:5.0.0_beta1-1 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package           Arch          Version               Repository          Size
================================================================================
Installing:
 packetbeat        x86_64        5.0.0_beta1-1         elastic-5.x        9.2 M

Transaction Summary
================================================================================
Install  1 Package

Total size: 9.2 M
Installed size: 31 M
Downloading packages:


Package packetbeat-5.0.0-beta1-x86_64.rpm is not signed

I tried with Elasticsearch, Kibana, Metricbeat and the results are same. Are the .rpm files wrong?


(Tudor Golubenco) #2

I just tried the instructions on a Centos 6 and it worked for me without any issues. Can you make sure the GPG key is loaded? sudo rpm --import https://packages.elastic.co/GPG-KEY-elasticsearch


(Tudor Golubenco) #3

Agh, sorry! It indeed seems to be an issue. I'm raising it internally.


(Shin Tanimoto) #4

Yes, please!


(system) #5

This topic was automatically closed after 21 days. New replies are no longer allowed.