Cannot get Beats to monitor with Metricbeat


Elastic 7.11.1

I have configured metricbeat, and I have got rid of this legacy monitoring, but I cannot seem to get rid of this message:

I click onto "Monitor with Metricbeat"

I have done:
metricbeat modules enable beat-xpack

I also have enabled these modules:

# ls -lh /etc/metricbeat/modules.d/*.yml
-rw-r--r-- 1 root root 255 Mar  4 19:21 /etc/metricbeat/modules.d/beat-xpack.yml
-rw-r--r-- 1 root root 340 Mar  4 18:15 /etc/metricbeat/modules.d/elasticsearch-xpack.yml
-rw-r--r-- 1 root root 280 Mar  4 18:15 /etc/metricbeat/modules.d/kibana-xpack.yml
-rw-r--r-- 1 root root 822 Feb 15 15:48 /etc/metricbeat/modules.d/system.yml

I have modified metribeat.yml and checked all these modules.d/ file contents.

# cat /etc/metricbeat/modules.d/beat-xpack.yml
# Module: beat
# Docs:

- module: beat
  xpack.enabled: true
  period: 10s
  hosts: ["http://localhost:5066"]
  username: "beats_system"


Looks like this was introduced in [Monitoring] "Internal Monitoring" deprecation warning by igoristic · Pull Request #72020 · elastic/kibana · GitHub

@chrisronline how would you recommend identifying which .monitoring-* indices are legacy?

Hi @raulk89,

Did you disable legacy monitoring collection through the ES cluster settings?

Can you share the result of GET _cluster/settings?

I did yeah.
Here is the output.

  "persistent" : {
    "xpack" : {
      "monitoring" : {
        "elasticsearch" : {
          "collection" : {
            "enabled" : "false"
  "transient" : { }

Seems like, the problem was this:


# ============================= X-Pack Monitoring ==============================
# Metricbeat can export internal metrics to a central Elasticsearch monitoring
# cluster.  This requires xpack monitoring to be enabled in Elasticsearch.  The
# reporting is disabled by default.

# Set to true to enable the monitoring reporter.
#monitoring.enabled: false

Which is strange. Since there is a statement:

The reporting is disabled by default

So it should have been false. When I uncommented this value, like this:

monitoring.enabled: false

Then after some 30 seconds, kibana started showing N/A for metricbeat monitoring..

So, seems like this "monitoring.enabled" default value is actually true..?

To get rid of this N/A, I had to additionally add these to metricbeat.yml

http.enabled: true
http.port: 5066

Then I got these blue messages:



Hmm. That doesn't sound like intended behavior, but I'll ping @Mario_Castro for some perspective on the Metricbeat side of things.


What is the status with this one..?


Have you had any luck..?


Are you still having an issue? I was under the impression you sorted it out

Correct, but I understood this was not intended behavior.
Any info on that..?


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.