Can't reach Kibana on localhost

Hey there,

I took the Eng I and II courses and now wanted to go through the labs on my local machine again to prepare for the certification.

I set up a VM with an ubuntu server on VMware in NAT mode (but bridged doesn't change the problem) and I can't seem to reach Kibana when going to http://localhost:5601 .

Cluster health is green, everything's fine, except the fact that I can't reach Kibana from my host.

Any idea on how to fix this issue ?

Sorry if the answer is already somewhere around, but I couldn't find it.

Thanks in advance for your help!

jsu

I would try configuring Kibana to bind to all available network interfaces. You can do so by providing this parameter on the command line when starting Kibana: --host=0.0.0.0

Hopefully that will resolve your issue.

Thanks for the quick answer abdon !

I just tried this but unfortunately it didn't work. Still "unable to connect".

EDIT : actually, with the --host=0.0.0.0, it worked when I connected to it with http://ip.of.the.vm:5601 and not with http://localhost:5601 .
Thanks a lot for the help !

2 Likes