Canvas not working with kibana 6.1.1


(Josh Speer) #1

Just tried to install canvas in my test env, receiving this error:

Incorrect Kibana version in plugin [canvas]. Expected [6.0.0]; found [6.1.1]


(Tyler Smalley) #2

Did you follow the installation instructions here?


(Josh Speer) #3

Those are the instructions I used, however I'm using a platinum license so I left this part off:

xpack.license.self_generated.type: basic

I just tried it with the above line, and I still receive the same error, and no machine learning/graph in kibana.

NODE_OPTIONS="--max-old-space-size=4096" /usr/share/kibana/bin/kibana-plugin install 
file:///home/speer/kibana-canvas-0.1.1736.zip
Attempting to transfer from file:///home/speer/kibana-canvas-0.1.1736.zip
Transferring 16023012 bytes....................
Transfer complete
Retrieving metadata from plugin archive
Extracting plugin archive
Extraction complete
Plugin installation was unsuccessful due to error "Incorrect Kibana version in plugin [canvas]. Expected 
[6.0.0]; found [6.1.1]"

(Tyler Smalley) #4

It appears you're using 6.0.0 - The Canvas preview requires the latest GA versions of Elasticsearch, Kibana, and X-Pack which is currently 6.1.1.


(Josh Speer) #5

You are correct, I'm running 6.0.0. I didn't read that error message correctly. I took it to mean that it wanted 6.0.0 installed, but was seeing something identifying as 6.1.1. I'm in the process of upgrading them now.

Thanks!


(Josh Speer) #6

I've upgraded elasticsearch, kibana, and x-pack to the latest version. When I try to start kibana, I receive this message:

log   [21:11:15.479] [info][optimize] Optimizing and caching bundles for canvas, graph, monitoring, ml, apm, kibana, stateSessionStorageRedirect, timelion, login, logout, dashboardViewer and status_page. This may take a few minutes

<--- Last few GCs --->

  740374 ms: Mark-sweep 1176.6 (1434.2) -> 1170.9 (1434.2) MB, 1375.3 / 0.0 ms [allocation failure] [GC in old space requested].
  741824 ms: Mark-sweep 1170.9 (1434.2) -> 1170.9 (1434.2) MB, 1449.2 / 0.0 ms [allocation failure] [GC in old space requested].
  743234 ms: Mark-sweep 1170.9 (1434.2) -> 1180.8 (1403.2) MB, 1409.9 / 0.0 ms [last resort gc].
  744717 ms: Mark-sweep 1180.8 (1403.2) -> 1190.7 (1403.2) MB, 1483.3 / 0.0 ms [last resort gc].


<--- JS stacktrace --->

==== JS stack trace =========================================

Security context: 0x189e834cf781 <JS Object>
    2: _visit [0x189e83404381 <undefined>:1339] [pc=0x32574f4ec0d2] (this=0x1d5aa190da29 <a TreeWalker with map 0x2e6358121cb9>,node=0x1bfa6b74c079 <an AST_SymbolRef with map 0x3e850cf7a239>,descend=0x189e83404381 <undefined>)
    3: arguments adaptor frame: 1->2
    4: _walk [0x189e83404381 <undefined>:480] [pc=0x32574f4eb713] (this=0x1bfa6b74c079 <an AST_SymbolRef with map 0x3e850cf7a239>,vis...

FATAL ERROR: CALL_AND_RETRY_LAST Allocation failed - JavaScript heap out of memory
 1: node::Abort() [/usr/share/kibana/bin/../node/bin/node]
 2: 0x10a03bc [/usr/share/kibana/bin/../node/bin/node]
 3: v8::Utils::ReportApiFailure(char const*, char const*) [/usr/share/kibana/bin/../node/bin/node]
 4: v8::internal::V8::FatalProcessOutOfMemory(char const*, bool) [/usr/share/kibana/bin/../node/bin/node]
 5: v8::internal::Factory::NewCode(v8::internal::CodeDesc const&, unsigned int, v8::internal::Handle<v8::internal::Object>, bool, bool, int, bool) [/usr/share/kibana/bin/../node/bin/node]
 6: v8::internal::CodeGenerator::MakeCodeEpilogue(v8::internal::MacroAssembler*, v8::internal::CompilationInfo*) [/usr/share/kibana/bin/../node/bin/node]
 7: v8::internal::FullCodeGenerator::MakeCode(v8::internal::CompilationInfo*) [/usr/share/kibana/bin/../node/bin/node]
 8: v8::internal::Compiler::EnsureDeoptimizationSupport(v8::internal::CompilationInfo*) [/usr/share/kibana/bin/../node/bin/node]
 9: 0xb56147 [/usr/share/kibana/bin/../node/bin/node]
10: 0xb575bd [/usr/share/kibana/bin/../node/bin/node]
11: v8::internal::Compiler::CompileOptimized(v8::internal::Handle<v8::internal::JSFunction>, v8::internal::Compiler::ConcurrencyMode) [/usr/share/kibana/bin/../node/bin/node]
12: v8::internal::Runtime_CompileOptimized_Concurrent(int, v8::internal::Object**, v8::internal::Isolate*) [/usr/share/kibana/bin/../node/bin/node]
13: 0x3257494092a7
Aborted

I still have 6GB free RAM.


(Josh Speer) #7

I remove x-pack and canvas, then installed both plugins using:

NODE_OPTIONS="--max-old-space-size=4096" 

It's now working.


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.