Cluster Status: Red and License Status: Expired

Forgive my ignormace I am still trying to wrap my brain around all of the idiosyncrasies of ELK. I have tried everything I can thing of to bring my cluster back online.

curl -XGET http://p-es-2:9200/_license
"license" : {
"status" : "expired",
"uid" : "45dbdbcc-82a3-436f-b01d-4e645b73a078",
"type" : "trial",
"issue_date" : "2016-04-28T18:45:02.261Z",
"issue_date_in_millis" : 1461869102261,
"expiry_date" : "2016-05-28T18:45:02.261Z",
"expiry_date_in_millis" : 1464461102261,
"max_nodes" : 1000,
"issued_to" : "Elasticsearch-Cluster-1",
"issuer" : "elasticsearch"

Ive tried removing and re-installing the license plugin, rebooting on each of the 3 nodes in the cluster. I guess I dont have a clear understanding as to whats going on exactly. Anyone have any thoughts?

What plugins do you have installed?

While trying to troubleshoot I have removed all plugins from all of my hosts. But initially it was Marvel and License

Can you check with _cat/plugins?

Returns no results

Can you check /usr/share/elasticsearch/plugins and see if there is anything in there?

It definitely shouldn't be doing this, but I haven't seen this sort of thing.