[security_exception] current license is non-compliant for [security], with { license.expired.feature="security" }


(Keith Tt) #1

ELK version: 5.5.1

I restart one of my ES node, and the ES cluster turns red and can't be accessed.

[security_exception] current license is non-compliant for [security], with { license.expired.feature="security" }

what is wrong........I have updated my license to basic a free days ago.

# curl -XGET 'http://192.168.3.56:9200/_cluster/health?pretty=true'
{
  "error" : {
    "root_cause" : [
      {
        "type" : "security_exception",
        "reason" : "current license is non-compliant for [security]",
        "license.expired.feature" : "security"
      }
    ],
    "type" : "security_exception",
    "reason" : "current license is non-compliant for [security]",
    "license.expired.feature" : "security"
  },
  "status" : 403
}
# curl -XGET 'http://192.168.3.56:9200/_xpack/license'
{
  "license" : {
    "status" : "active",
    "uid" : "01b569ae-58cf-432c-be06-32d2f1395358",
    "type" : "basic",
    "issue_date" : "2017-07-24T00:00:00.000Z",
    "issue_date_in_millis" : 1500854400000,
    "expiry_date" : "2018-07-24T23:59:59.999Z",
    "expiry_date_in_millis" : 1532476799999,
    "max_nodes" : 100,
    "issued_to" : "shengyong pei (opera)",
    "issuer" : "Web Form",
    "start_date_in_millis" : 1500854400000
  }
}


(Tim Sullivan) #2

The Basic license doesn't support the Security feature, so you'll need to disable Security in elasticsearch.yml and kibana.yml with xpack.security.enabled: false

This is documented in https://www.elastic.co/guide/en/x-pack/current/installing-xpack.html#xpack-enabling


(Keith Tt) #3

Thanks tsullivan, resolved by restarting kibana nodes, maybe it is a coincidence, and I do not think it is necessary to set this parameter xpack.security.enabled: false in config file, as you said the basic license do not support security...


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.