Completely disable Kibana Timeout


(Jason) #1

We are running on not so good hardware (business choice.... why would monitoring be important?) , so am placed in a position where I want to increase the time out for Kibana. I am running 4.4.2 and for some reason it seems to ignore the timeout value when I increase it.

One of the other annoying things, is when a query does time out, Kibana then throws the status page saying that a query took more than 30 seconds. Don't really care about that, because that query has been and gone, but then you can't actually do anything useful with Kibana for a while afterwards, as it wants you to know that a timeout has occurred.


(Mark Walkom) #2

You can't disable it without hacking the code.
You can increase the timeout to some crazy number if you want, take a look at the options here - https://www.elastic.co/guide/en/kibana/current/kibana-server-properties.html


(Jason) #3

I am setting

elasticsearch.requestTimeout: 900000

however in the kibana dashboard it still reports

plugin:elasticsearch Request Timeout after 30000ms

It just also seems that once it encounters a timeout error, you can't get it to do another search for a while.


(Alex) #4

im running in the same problem.. no solution at all ?


(Melpheos) #5

Same issue here. Despite changing the parameter is Kibana.yml file, the timeout stays at 30s


(Justin Crossman) #6

Same issue here. I'm using a Bitnami ELK stack via AWS so perhaps it's more involved? E.g. there is an overriding config?


(system) #7