Connect Kibana to remote Elasticsearch


(Mladen Korunoski) #1

Hi everyone.

I am beginner in using Elasticsearch, and Kibana for that matter. I am experiencing problem for which I am not able to find a solution.

First of all, I have an Elasticsearch server with couple of indices, running on IBM Bluemix. I have local Kibana instance that I've configured to connect to that server. All well and good but when I try to create index patterns in Kibana for the particular indices in ES i get "Authentication Error" at the top of my browser with the following stack trace:

Error: Authentication Exception
request/<@http://localhost:5601/bundles/commons.bundle.js?v=16588:1:688912
processQueue@http://localhost:5601/bundles/vendors.bundle.js?v=16588:58:132456
scheduleProcessQueue/<@http://localhost:5601/bundles/vendors.bundle.js?v=16588:58:133349
$digest@http://localhost:5601/bundles/vendors.bundle.js?v=16588:58:144239
$apply@http://localhost:5601/bundles/vendors.bundle.js?v=16588:58:147007
done@http://localhost:5601/bundles/vendors.bundle.js?v=16588:58:100015
completeRequest@http://localhost:5601/bundles/vendors.bundle.js?v=16588:58:104697
createHttpBackend/</xhr.onload@http://localhost:5601/bundles/vendors.bundle.js?v=16588:58:105435

Any help is appreciated.


(Archana ) #2

Hi, welcome to the Elastic Stack!

This suggests that the user you're logged into Kibana as, does not have the right permissions for those indices in Elasticsearch, or that you don't have rights to create objects (like index patterns) in Kibana. What is your security setup in Elasticsearch?


(Mladen Korunoski) #3

Thank you for the reply.

I am using the provided credentials from Bluemix, namely the username and password (I am not certain about other security mechanism that Compose for ES might use, so I have to check that). The browser requests these when starting Kibana. I also specified them in the kibana.yml file before starting it.

I am able to use the Dev Tools page, though.


(Archana ) #4

Sounds like you should be asking this question in the IBM Bluemix organization, or speak to your administrator. I did a google search and found this: https://console.bluemix.net/docs/services/CloudLogAnalysis/qa/faq_kibana.html#logging_qa_no_data_dashboard_kibana "What do I do if I get an authentication exception"


(Mladen Korunoski) #5

I will.

Thank you for the support.


(James Wiltshire) #6

I have been having the same issue, and it seemed to start this week. We are running Kibana local and connecting to Compose Elastic Search, and it appears that Kibana isn't passing the authorization header to Compose Elastic in some cases. I was able to get it working by adding this to kibana.yml:
elasticsearch.customHeaders: { Authorization: Basic XXXXXXXetc }
where XXXXXXXetc is the Base64 encoding of the string id:password

I continue to let elasticsearch.requestHeadersWhitelist default. I haven't thoroughly tested but the first few pages that were receiving 401 status codes are now rendering correctly; hope this works for you.


(Mladen Korunoski) #7

That fixed it for me. I am now able to create index patterns and do the visualization.

Thank you so much!


(Sneha) #8

Thanks James...

It worked for me as well :slight_smile: :slight_smile: :slight_smile:


(system) #9

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.