Could not start Kibana after install X-Pack


#1

I installed X-Pack witn the command ./bin/kibana-plugin install x-pack
And I launched the Elasticsearch and Kibana,the Elasticsearch started successfully but Kibana failed.

the Kibana logs are as follow:
[XXX@foxbert bin]$ ./kibana
log [13:08:47.863] [info][optimize] Optimizing and caching bundles for ml, stateSessionStorageRedirect, status_page, timelion, graph, monitoring, login, logout, dashboardViewer, apm and kibana. This may take a few minutes
Killed

Do I need to uninstall the x-pack from kibana?
What should I do?


(Ioannis Kakavas) #2

Hi

Did you also install X-Pack on Elasticsearch ? You need to install X-Pack in all of the components of the stack. See an overview of the procedure here
You would need to install x-pack in Elasticsearch too and perform the basic configuration before the rest of the troubleshooting can continue, but if you run into additional issues afterwards please also share the following in your update:

  • What is your OS ?
  • The lines in kibana.yml that are not commented out
  • Log output from /var/log/kibana/kibana.log

#3

Yes,I have installed X-Pack on my Elasticsearch. I deployed my ES on the cloud

server.My OS is Linux withCentOS7.4.

mykibana.yml
# Kibana is served by a back end server. This setting specifies the port to use.
server.port: 5601

        # Specifies the address to which the Kibana server will bind. IP addresses and 

host names are both valid values.
        # The default is 'localhost', which usually means remote machines will not be 

able to connect.
        # To allow connections from remote users, set this parameter to a non-

loopback address.
        #server.host: "localhost"
        server.host: "172.18.183.220"

        # Enables you to specify a path to mount Kibana at if you are running behind a 

proxy. This only affects
        # the URLs generated by Kibana, your proxy is expected to remove the 

basePath value before forwarding requests
        # to Kibana. This setting cannot end in a slash.
        #server.basePath: ""

        # The maximum payload size in bytes for incoming server requests.
        #server.maxPayloadBytes: 1048576

        # The Kibana server's name.  This is used for display purposes.
        #server.name: "your-hostname"

        # The URL of the Elasticsearch instance to use for all your queries.
        #elasticsearch.url: "http://localhost:9200"
        elasticsearch.url: "http://120.79.223.63:9200"
        #elasticsearch.url: "http://172.18.183.220:9200"
        elasticsearch.username: "elastic"                          
        elasticsearch.password: "changeme" 
        tilemap.url: 'http://webrd02.is.autonavi.com/appmaptile?

lang=zh_cn&size=1&scale=1&style=7&x={x}&y={y}&z={z}' 
        #这个配置是把kibana中的带的地图换成中文的地图
        # When this setting's value is true Kibana uses the hostname specified in the 

server.host
        # setting. When the value of this setting is false, Kibana uses the hostname of 

the host
        # that connects to this Kibana instance.
        #elasticsearch.preserveHost: true

        # Kibana uses an index in Elasticsearch to store saved searches, visualizations 

and
        # dashboards. Kibana creates a new index if the index doesn't already exist.
        #kibana.index: ".kibana"

        # The default application to load.
        #kibana.defaultAppId: "home"

        # If your Elasticsearch is protected with basic authentication, these settings 

provide
        # the username and password that the Kibana server uses to perform 

maintenance on the Kibana
        # index at startup. Your Kibana users still need to authenticate with 

Elasticsearch, which
        # is proxied through the Kibana server.
        #elasticsearch.username: "user"
        #elasticsearch.password: "pass"

        # Enables SSL and paths to the PEM-format SSL certificate and SSL key files, 

respectively.
        # These settings enable SSL for outgoing requests from the Kibana server to 

the browser.
        #server.ssl.enabled: false
        #server.ssl.certificate: /path/to/your/server.crt
        #server.ssl.key: /path/to/your/server.key

        # Optional settings that provide the paths to the PEM-format SSL certificate 

and key files.
        # These files validate that your Elasticsearch backend uses the same key files.
        #elasticsearch.ssl.certificate: /path/to/your/client.crt
        #elasticsearch.ssl.key: /path/to/your/client.key

        # Optional setting that enables you to specify a path to the PEM file for the 

certificate
        # authority for your Elasticsearch instance.
        #elasticsearch.ssl.certificateAuthorities: [ "/path/to/your/CA.pem" ]

        # To disregard the validity of SSL certificates, change this setting's value to 

'none'.
        #elasticsearch.ssl.verificationMode: full

        # Time in milliseconds to wait for Elasticsearch to respond to pings. Defaults to 

the value of
        # the elasticsearch.requestTimeout setting.
        #elasticsearch.pingTimeout: 1500

It 's very strange that I can' t find the kibana.log in the/var/log/. There is nokibana folder in my directory.

I put kibana uninstall and reinstall the time, but had a new problem:
[root@foxbert bin]# ./kibana-plugin install x-pack
Found previous install attempt. Deleting...
Attempting to transfer from x-pack
Attempting to transfer from https://artifacts.elastic.co/downloads/kibana-plugins/x-pack/x-pack-6.2.4.zip
Transferring 264988487 bytes....................
Transfer complete
Retrieving metadata from plugin archive
Extracting plugin archive
Extraction complete
Optimizing and caching browser bundles...
Killed

what should I do?


(Ioannis Kakavas) #4

It looks as if your VM doesn't have enough memory for X-Pack to complete the installation. This has been reported here and here and both times the issue was that the VM did not have enough available ram.

Please use a VM with adequate resources ( > 2GB of RAM ).


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.