DateTime format in CSV report is not correct. 0's are being appended for nanos

ES and kibana version v 7.17.3

When generating CSV report, datetime format is not correct.
0's are being appended for micro and nano seconds, although document holds correct values.


Tried playing around with advanced settings but still not able to solve this issue.

Please help :frowning:

I could reproduce this with 7.17.7 but I checked as well, and seems to be fixed on 8.6.0.

I've tried but I can't find the PR that fixed this issue so I can't provide more details , sorry :disappointed:

1 Like