Disables elastic and kibana users after a while


(Amir Salar Pourhasan) #1

After I'm using X--Pack basic authentication setting, it disables elastic and kibana users after some times working on my project? Then I have to reset these user's password then restart Elasticsearch and Kibana, then it will be work. in last 3 hours, I did it 4 times?!! why this is happening?


(David Pilato) #2

X-Back basic does not have security features.


(Amir Salar Pourhasan) #3

I meant X-pack free licensed. I have installed x-pack free license and it has set the password for my Elasticseach and Kibana. These are not fecurity features?


(Amir Salar Pourhasan) #4

I do not need any features like machine learning. I`m using Xpack free only for setting a password for users. If I miss understood, please correct me.
I want:

  • install my Elastic search and Kibana on my ubuntu server (that only response to localhost. I have now)
  • Access Kibana in the browser. I can not open in Kibana from ssh so I should use the browser. I the Kkibana only listen to localhost on my server, how can I access it vi for example http://200.50.60.30 ?
  • I need to deny all IP and only allow localhost and server real IP
  • I need set a password for elastic and Kibana users.

Do I need x-pack for those above fatures?


(David Pilato) #5

Security needs xpack gold or platinum.
You can have by default a trial license of 30 days.
The basic free license does not include security.

Have a look at https://www.elastic.co/subscriptions


(Amir Salar Pourhasan) #6

I think I found the problem. In developing mode, I use this command a lot "DELETE _all". From last night os far, I did not use this command and my application was working fine with lots of restarts. But now I just used that command for reconfiguration indicates, and suddenly it happened again.

My solution in DevMode:
I made another superuser and whenever it happens, I only use these commands fastly:

curl -u es_admin -XPUT 'http://localhost:9200/_xpack/security/user/elastic/_password?pretty' -H 'Content-Type: application/json' -d' { "password" : "oldElasticPassword"}' 
curl -u es_admin -XPUT 'http://localhost:9200/_xpack/security/user/kibana/_password?pretty' -H 'Content-Type: application/json' -d' { "password" : "oldKibanaPassword"}' 

"oldElasticPassword" and "oldKibanaPassword" are the password I was using before these users disabled. It means please get back to some minutes config (last passwords I was using) and I do not need to change any config files again.

Verifying users:

 curl -u elastic 'http://localhost:9200/_xpack/security/_authenticate?pretty'
 curl -u kibana 'http://localhost:9200/_xpack/security/_authenticate?pretty'

Then Restart:

systemctl restart kibana.service
systemctl restart elasticsearch.service

(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.