Elasticsearch 5.1.1 head plugin standalone server


(bowow) #1

Hi,
I have migrated to ELK Stack 5. I have learned that site plugins are no longer supported in ELK 5. Hence, i tried to run Elasticsearch-head plugin as a standalone server by following the directions of below link..

https://www.elastic.co/blog/running-site-plugins-with-elasticsearch-5-0
http://stackoverflow.com/questions/18336186/how-to-deploy-elasticsearch-head-or-some-other-browser-frontend-monitoring-tool

What i did was.. I set the following on elasticsearch.yml file.

http.cors.enabled: true
http.cors.allow-origin: "*"

Then i installed the following:

wget https://github.com/mobz/elasticsearch-head/archive/master.zip
unzip elastic-head-master.zip
cd elastic-head-master
open index.html

To check if it's working..
i tried the following in the browser
localhost:9100
localhost:9100/index.html
10.117.67.112:9100
10.117.67.112:9100

No luck on all of the above..

Then i cd into elasticsearch-head-master directory and did

python -m SimpleHTTPServer 9100
Serving HTTP on 0.0.0.0 port 9100 ...

still no luck..

Is there any steps I am missing out? Any help would be appreciated


(Petru Buzulan) #2

Just from console go to your head directory and run 'npm install'
After that just 'grunt server'
Example: cd C:\elasticsearch-head
npm install
grunt server
Chck localhost:9100
Enjoy


(bowow) #3

Hi,
I am using Redhat Linux. When I use the following command 'npm install'
I get npm: command not found error...


(Petru Buzulan) #4

Make sure you have Node and NPM installed by running simple commands to see what version of each is installed:
Test Node.js. To see if Node.js is installed, type node -v in the terminal. ...
Test NPM. To see if NPM is installed, type npm -v in the terminal.

If not, google how to install npm on linux


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.