Elasticsearch Head plugin is not working for after upgrading ES version from 1.x to 2.x


(chintan visani) #1

Hi ,
I am beginner to elastic search and using HEAD plugin as UI interface.I had worked with ES version of 1.3.2 ,working fine and now I had upgraded ES to version 2.3.2 both the server and client pc. I mean that I have installed ES at domain e.g. www.example.com and accessing it in my local with HEAD plugin as http://localhost:9200/_plugin/head.

Now when I try to access ES with browser e.g. www.example.com/_stats than it's working fine , but when I try to connect it with HEAD plugin than it shows 200 response and gives CORS related error on console. I have tried all configuration of elasticsearch.yml at my local by searching but it's doesn't seems to be work for me. I have attached images related to that.

Response Page Output :

Console Page Output :

accessing through browser :

I have tried
http.cors.enabled: true
http.cors.allow-origin: "*"
http.cors.allow-methods : OPTIONS, HEAD, GET, POST, PUT, DELETE
http.cors.allow-headers : X-Requested-With,X-Auth-Token,Content-Type, Content-Length
with my local configuration but can't work with HEAD plugin.

Thanks.


(Mark O Stewart) #2

Have you tried to uninstall the plugin and reinstall.
I think i had similar issues when going from 1.x to 2.x and the remove and reinstall plugin worked.

Also I would investigate the Kopf and HQ plugins.
Kopf is the newer head plugin and in my opinion a much improved interface vs head.


(chintan visani) #3

Thanks for the reply.

I have reinstalled head plugin and also reinstalled whole ES. But it does
not work for me.

I have also used kopf and HQ but head is a very clean ui that's why I
prefer it.

Anyway,
I need to know something that
Does head plugin is supported with newer version ?
And
What about CORS settings it is added either at client ES or Server ES or
Both?

Thanks.


(Mark O Stewart) #4

It is my understanding that CORs is not required on 2.x. I am not sure if all 2.x or just later versions.

I commented out CORS lines out of my configs after upgrading to 2.3.1


(chintan visani) #5

My problem has been resolved by adding these lines and I am able to connect other nodes by HEAD plugin.

network.host: 0.0.0.0
http.port: 9200
http.cors.enabled: true
http.cors.allow-origin: "*"


(system) #6