Elasticsearch migration plugin: Blank page

In order to upgrade our 1.5.2 elasticsearch to 2.x, I have successfully installed elasticsearch migration plugin v1.18, but when linking to http://localhost:9200/_plugin/migration/ I get blank page. also next command gives me nothing: curl -XGET http://localhost:9200/_plugin/migration/

What am I missing?

You have to upgrade first to 1.7 IIRC.

Thanks David, the issue was with the port. It worked with 9201

What? You have 2 nodes running on the same machine?

No, but when running elastic I get next output, and from there I saw the 9201:
[2016-07-12 11:24:15,204][INFO ][node ] [Hawkeye] version[1.5.2], pid[10223], build[62ff986/2015-04-27T09:21:06Z]
[2016-07-12 11:24:15,204][INFO ][node ] [Hawkeye] initializing ...
[2016-07-12 11:24:15,213][INFO ][plugins ] [Hawkeye] loaded [buzzilla-analyzers-plugin], sites []
[2016-07-12 11:24:17,398][INFO ][node ] [Hawkeye] initialized
[2016-07-12 11:24:17,398][INFO ][node ] [Hawkeye] starting ...
[2016-07-12 11:24:17,446][INFO ][transport ] [Hawkeye] bound_address {inet[/0:0:0:0:0:0:0:0:9301]}, publish_address {inet[/]}
[2016-07-12 11:24:17,457][INFO ][discovery ] [Hawkeye] elasticsearch/tNDxSlILRXqzHARGViivQA
[2016-07-12 11:24:21,223][INFO ][cluster.service ] [Hawkeye] new_master [Hawkeye][tNDxSlILRXqzHARGViivQA][dev015][inet[/]], reason: zen-disco-join (elected_as_master)
[2016-07-12 11:24:21,331][INFO ][http ] [Hawkeye] bound_address {inet[/0:0:0:0:0:0:0:0:9201]}, publish_address {inet[/]}
[2016-07-12 11:24:21,332][INFO ][node ] [Hawkeye] started
[2016-07-12 11:24:23,167][INFO ][gateway ] [Hawkeye] recovered [86] indices into cluster_state

Please format your code using </>.

It means that you have something running on port 9200.

What gives the following command?


curl: (7) Failed to connect to port 9200: Connection refused

Can you stop the node on 9201 and start Elasticsearch again?

I'm pretty sure you had at some point 2 nodes running on your machine.

It's still gets 9201, but it's OK David, its not the issue here. As long as I can run the migration plugin, and see it...
Thanks for the help!

The only explanation I can see is that you explicitly set the port in settings.