ELK 6.0.0 And Xpack 6.0.0 Username password is not working

Hi All ,

can you please explain the method of username and password entering criteria in Xpack installed ELK ( 6.0.0 ). 

Before installing Xpack , 6.0.0, ELK is working well. Xpack installed successfully.

First I am tried in Elasticsearch with command bin/x-pack/setup-passwords interactive.

Password for E , L and K i am entered the same password "000029".

And in kibana.yml

elasticsearch.username: "kibana"
elasticsearch.password: "kibanapassword"

And in logstash.yml

xpack.monitoring.elasticsearch.username: u12345(cent Os username )
xpack.monitoring.elasticsearch.password: 000029 ( Not Centos username . As per Elastic search entry )

It is not working. Kibana showing Login in locked.

Please help me to configure these usernames and passwords properly.

E, L and K are installed on the same machine. OS is CentOS. User u12345, Password: xyz123.

u12345 is using for E, L, and K search installations.

Hello Rijin,

Please go through the detailed instructions in here and here . Following these steps will guarantee that you have a working and secure environment in the end.

One obvious problem I see is that in kibana.yml, you should set the password to 000029 and not kibanapassword as you have it now. Also xpack.monitoring.elasticsearch.username should probably not be the OS username, you can read more here.

As a general note, it is a good practice to not share your passwords in public forums, even though the above seem like temporary test credentials.

Thank you Ikakavas ,

These usernames and passwords are not real. :slight_smile: My doubt is elasticsearch.username: "kibana" is any label or Kibana using OS user ?
I want to inform one more thing , i am not configured SSL/TLS.

Not added this to elastisearch.yml

xpack.ssl.key: certs/${node.name}/${node.name}.key
xpack.ssl.certificate: certs/${node.name}/${node.name}.crt
xpack.ssl.certificate_authorities: certs/ca/ca.crt
xpack.security.transport.ssl.enabled: true


Let's take it one problem at a time :slight_smile:

My doubt is elasticsearch.username: "kibana" is any label or Kibana using OS user ?

This is not an OS user, this the builtin user that kibana uses to connect to elasticsearch. According to the information you have shared so far, your kibana.yml file should look like

elasticsearch.username: "kibana"
elasticsearch.password: "000029"

TLS/SSL is not directly related to the above problem. Once this is solved you can setup TLS using the documentation as guidance.

Thank you ikakavas . I will check

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.