Enable / Disable anonymous usage statistics by default?

Hi,

Is there a way to enable / disable anonymous usage statistics in kibana by configuration, so that no one has to answer this question manually?
Any variable in kibana.yml?

Thanks, Andreas

hello @asp - https://www.elastic.co/guide/en/kibana/current/settings.html - look for telemetry - I think you'll find what you need.

Thanks,
Matt

Hey @mattkime, thanks for your reply.

I added the following to kibana.yml

# configure Telemetry
telemetry.allowChangingOptInStatus: false
telemetry.optIn: false
telemetry.enabled: false

But kibana is not starting anymore, showing me the following errors:

{"type":"log","@timestamp":"2020-01-14T07:18:37Z","tags":["fatal","root"],"pid":20059,"message":"{ Error: \"telemetry.allowChangingOptInStatus\", \"telemetry.optIn\", and \"telemetry.enabled\" settings were not applied. Check for spelling errors and ensure that expected plugins are installed.\n at KbnServer._default (/usr/share/kibana/src/legacy/server/config/complete.js:90:17) code: 'InvalidConfig', processExitCode: 64 }"}

Any idea?
Thanks, Andreas

ok, I've overseen that telemetry.allowChangingOptInStatus and telemetry.optIn must not be false at the same time.

I also tried just to set telemetry.enabled: false and commented out the other ones, but I still get the error

{"type":"log","@timestamp":"2020-01-14T07:26:52Z","tags":["fatal","root"],"pid":29366,"message":"{ Error: \"telemetry.enabled\" setting was not applied. Check for spelling errors and ensure that expected plugins are installed.\n at KbnServer._default (/usr/share/kibana/src/legacy/server/config/complete.js:90:17) code: 'InvalidConfig', processExitCode: 64 }"}

Using kibana 7.4.1

It appears that the setting was introduced in v7.5 as its not documented in v7.4 - https://www.elastic.co/guide/en/kibana/7.4/settings.html

Ah great, thanks a lot. Then I will checkout 7.5 as soon as I can.

Thanks, Andreas