Enable Remote Access Kibana

Hi -
I have started Metric beats on a remote server, which is kept sending data to the Elastic search.

I have hosted Elastic Search and Kibana on a different Remote machine, Am able to access the Elastic Search.
Could you please let me know how do I enable remote access to the Kibana, so it can be accessed from anywhere on the domain. Thanks !

Regards,
Prakash

https://www.elastic.co/guide/en/kibana/current/settings.html, look at server.host.

1 Like

Hi @warkolm:

Below is the configuration of the Kibana.yml file:
But, still I couldn't able to connect to the Kibana server, even after successful start of the bat file.

server.port: 5601
server.host: "10.20.159.109" (same as my VM Windows IP)
server.basePath: "/kibana"
server.maxPayloadBytes: 1048576
server.name: "your-hostname"
elasticsearch.url: "http://localhost:9200"

Could you please let me know if anything needs to be changed. Thanks !

What happens then?

Hi @warkolm:
I couldn't access the Kibana locally as well (http://10.20.159.109:5601/kibana) :frowning:
Not sure, where was the mistake, could you please help me to figure it out.

I get the below error on the chrome

Thanks !

That is not a valid URL, see https://www.elastic.co/guide/en/kibana/current/access.html

Hi @warkolm

Neither of the URL's work, "http://10.20.159.109:5601/status, http://10.20.159.109:5601/"
It stopped working at local as well.

but the server shows up and running:

Hi @warkolm -
Am able to launch the Kibana locally, but couldn't able to access else where.
I tried accessing in another machine with in the same domain, but no luck, same with Elastic Search as well.
Couldn't connect to the Elastic search from a different machine.

Please help. Thanks !

Same for me. I allowed it in ufw, restarted the service, and adjusted the config file with my hostname: nothing. I can curl the webpage locally but it doesn't load remotely.

@warkolm

I am having a similar issue of not being able to access Kibana remotely as well. I've edited the kibana.yml file so that server.host is "0.0.0.0" with no luck. I've also tried it with the public IP of the server that kibana is running on. On the actual machine I can't seem to access it from the server's own private IP either.

I also allowed the port in ufw (running on ubuntu 14.04). I am using version 5.2

Same here as well. was anybody able to get it work?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.