error[EPERM]Operation not permitted


(Yong Rhee) #1

Hello, After reinstalled Kibana and Elasticsearch, things are not easy for me now.

This is Window 10 machine and both are 6.3.0
I installed Elasticsearch with msi file and did Kibana with zip file and unzip.
I got Auto password for all applications previously and It works for the new installed versions as well.
So I modified kibana.yml elasticsearh.user and .pass setting.

this is log from kibana execution after launched elasticsearch.
I have no idea why Kibana does not work now... help me
plus, there is no information in 'bable-register.json' file
.

9200

C:\Program Files\kibana-6.3.0-windows-x86_64\bin>kibana.bat
fs.js:646
  return binding.open(pathModule._makeLong(path), stringToFlags(flags), mode);
                 ^
    Error: EPERM: operation not permitted, open 'C:\Program Files\kibana-6.3.0-windows-x86_64\optimize\.babelcache.json'
        at Object.fs.openSync (fs.js:646:18)
        at Object.fs.writeFileSync (fs.js:1299:33)
        at save (C:\Program Files\kibana-6.3.0-windows-x86_64\node_modules\babel-register\lib\cache.js:45:16)
        at _combinedTickCallback (internal/process/next_tick.js:131:7)
        at process._tickCallback (internal/process/next_tick.js:180:9)
        at Function.Module.runMain (module.js:695:11)
        at startup (bootstrap_node.js:188:16)
        at bootstrap_node.js:609:3`Preformatted text`

(Larry Gregory) #2

Hi @Yong_Rhee,

We've seen this symptom on Windows machines before, and it seems that temporarily disabling anti-virus/anti-malware fixes this problem.

Can you try this and let me know if that helps?


(Yong Rhee) #3

I tried deactivate anti-virus/anti-malware program and got same result.
I also found strange log when I tried to connect localport:9200 with the "elastic" : "AUTO password" although it seems that it is not relevant to the Kibana connection issue.
I also retrieved my machine to the Window system point where I installed Elasticsearch which is couple days ago (It doesn't make any difference regarding this issue)

[2018-06-20T14:04:26,900][INFO ][o.e.x.s.a.AuthenticationService] [DESKTOP-C93E9FL] Authentication of [elastic] was terminated by realm [reserved] - failed to authenticate user [elastic]

It is really strange... for window machine I got different log every time I tried differently. Can I try with Ubuntu on Window10 to make it works (although I don't know how to do it)?


(Larry Gregory) #4

The authentication error you see is expected if you provide an invalid username/password combination, and you're right, that's unrelated to your Kibana issue.

EPERM: operation not permitted

This is a very general Windows OS error, so all we know is that something on your machine is preventing C:\Program Files\kibana-6.3.0-windows-x86_64\optimize\.babelcache.json from being accessed. If it's not AV, then it's possible that your user account does not have the appropriate privileges for that directory/file. Have you tried running Kibana with administrator privileges?

If that doesn't work, then you're more than welcome to try to install the Kibana Debian distribution under the Ubuntu subsytem


(Yong Rhee) #5

Thanks Larry.
Apparently, administrator privileges gave me some improvement. It goes to connection with following logs. And I was able to Kibana login window. However, from there, I am still not able to log in because of the following statement.

ps. I am still using credentials that I have auto generated at the first place when I installed elastic search. It is reflected in kibana.yml (user and password)
Both X-pack installed. (I think)

(Login is currently disabled. Administrators should consult the Kibana logs for more details.)

  log   [04:21:48.705] [error][status][plugin:index_management@6.3.0] Status changed from red to red - [security_exception] missing authentication token for REST request [/_xpack], with { header={ WWW-Authenticate="Basic realm=\"security\" charset=\"UTF-8\"" } }
  log   [04:21:48.706] [error][status][plugin:graph@6.3.0] Status changed from red to red - [security_exception] missing authentication token for REST request [/_xpack], with { header={ WWW-Authenticate="Basic realm=\"security\" charset=\"UTF-8\"" } }
  log   [04:21:48.707] [error][status][plugin:security@6.3.0] Status changed from red to red - [security_exception] missing authentication token for REST request [/_xpack], with { header={ WWW-Authenticate="Basic realm=\"security\" charset=\"UTF-8\"" } }
  log   [04:21:48.708] [error][status][plugin:grokdebugger@6.3.0] Status changed from red to red - [security_exception] missing authentication token for REST request [/_xpack], with { header={ WWW-Authenticate="Basic realm=\"security\" charset=\"UTF-8\"" } }
  log   [04:21:48.709] [error][status][plugin:logstash@6.3.0] Status changed from red to red - [security_exception] missing authentication token for REST request [/_xpack], with { header={ WWW-Authenticate="Basic realm=\"security\" charset=\"UTF-8\"" } }
  log   [04:21:48.710] [error][status][plugin:reporting@6.3.0] Status changed from red to red - [security_exception] missing authentication token for REST request [/_xpack], with { header={ WWW-Authenticate="Basic realm=\"security\" charset=\"UTF-8\"" } }
  log   [04:21:53.724] [info][listening] Server running at http://localhost:5601
  log   [04:22:18.705] [warning][license][xpack] License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. [security_exception] missing authentication token for REST request [/_xpack], with { header={ WWW-Authenticate="Basic realm=\"security\" charset=\"UTF-8\"" } } :: {"path":"/_xpack","statusCode":401,"response":"{\"error\":{\"root_cause\":[{\"type\":\"security_exception\",\"reason\":\"missing authentication token for REST request [/_xpack]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}}],\"type\":\"security_exception\",\"reason\":\"missing authentication token for REST request [/_xpack]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}},\"status\":401}","wwwAuthenticateDirective":"Basic realm=\"security\" charset=\"UTF-8\""}
  log   [04:22:48.720] [warning][license][xpack] License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. [security_exception] missing authentication token for REST request [/_xpack], with { header={ WWW-Authenticate="Basic realm=\"security\" charset=\"UTF-8\"" } } :: {"path":"/_xpack","statusCode":401,"response":"{\"error\":{\"root_cause\":[{\"type\":\"security_exception\",\"reason\":\"missing authentication token for REST request [/_xpack]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}}],\"type\":\"security_exception\",\"reason\":\"missing authentication token for REST request [/_xpack]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}},\"status\":401}","wwwAuthenticateDirective":"Basic realm=\"security\" charset=\"UTF-8\""}
  log   [04:23:18.732] [warning][license][xpack] License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. [security_exception] missing authentication token for REST request [/_xpack], with { header={ WWW-Authenticate="Basic realm=\"security\" charset=\"UTF-8\"" } } :: {"path":"/_xpack","statusCode":401,"response":"{\"error\":{\"root_cause\":[{\"type\":\"security_exception\",\"reason\":\"missing authentication token for REST request [/_xpack]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}}],\"type\":\"security_exception\",\"reason\":\"missing authentication token for REST request [/_xpack]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}},\"status\":401}","wwwAuthenticateDirective":"Basic realm=\"security\" charset=\"UTF-8\""}
  log   [04:23:48.750] [warning][license][xpack] License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. [security_exception] missing authentication token for REST request [/_xpack], with { header={ WWW-Authenticate="Basic realm=\"security\" charset=\"UTF-8\"" } } :: {"path":"/_xpack","statusCode":401,"response":"{\"error\":{\"root_cause\":[{\"type\":\"security_exception\",\"reason\":\"missing authentication token for REST request [/_xpack]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}}],\"type\":\"security_exception\",\"reason\":\"missing authentication token for REST request [/_xpack]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}},\"status\":401}","wwwAuthenticateDirective":"Basic realm=\"security\" charset=\"UTF-8\""}


(Larry Gregory) #6

Can you check your kibana.yml file and verify that you have elasticsearch.username and elasticsearch.password set and configured correctly? This is needed so that the Kibana server can authenticate to Elasticsearch.

See https://www.elastic.co/guide/en/kibana/current/settings.html for more information on configuring Kibana


(Yong Rhee) #7

Thank you! This ticket is resolved!


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.