Error fetching fields for index pattern

I've just upgraded a k8s self managed installation of es with Kibana.
When it was not secured, I created some indexes and dashboards.

When I added xpack,
In elasticasearch.yaml file:
( true
authz_exception: true
roles: superuser
username: anonymous)

and then adding

    value: "true"

to kibana in order to make the healtch check pass.

But now, I can access securely, but I cannot create indexes patterns based in my indeces.

When creating it,
Error fetching fields for index pattern sda*

also, I cannot list dashboards: * Fetching listing failed

The dashboard listing could not be fetched: Failed to fetch.*


Welcome to our community! :smiley:

Please format your code/logs/config using the </> button, or markdown style back ticks. It helps to make things easy to read which helps us help you :slight_smile: As your post is now, it's a little hard to follow what is code/errors and what is text.

If you are getting errors, then sharing the entire thing is helpful. If it's in Kibana, then take a screenshot and attach it here. If it's something text, copy and past the entirety, making sure to code format it.

Firstly, I think what I’m trying to do is not possible.

I have a es +Kibana working with no x pack.

I have to have users in Kibana that would use the same data/dashboards I have in ES.

In order to do that, installed xpack in ES as mentioned earlier in my first message.

Anything else I should do?

What version are you working with here?


Ok, you don't need to install X-Pack, it's bundled. You do need to configure it.

If you want to enable anonymous access then please check out Enabling anonymous access | Elasticsearch Guide [7.12] | Elastic and make sure you have followed the appropriate steps.
It is not recommended to use anonymous access for Kibana though, you should set that up properly using the included Kibana system user and role. If you do that then you won't run into these permission errors.

I’ve done that, but afterwards when using the default users and passwords I cannot see my index pttern or dashboards.

Ok, can you show us a screenshot of your index patterns in the relevant Kibana settings page?

I know what happened.
If you use Brave it won't work.
Note: it worked when no security was enabled. That was what shocked me, and thought it wasn't working. Would be nice to add that kind of message.

Refused to execute inline script because it violates the following Content Security Policy directive: "script-src 'unsafe-eval' 'self'". Either the 'unsafe-inline' keyword, a hash ('sha256-P5polb1UreUSOe5V/Pv7tc+yeZuJXiOi/3fqhGsU7BE='), or a nonce ('nonce-...') is required to enable inline execution.


but works fine with safari.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.