Error on discover

When I access the Discover screen the following error appears:

I ran the following command to rebuild the index pattern apm- *:

apm-server setup

Kibana version: 7.5

@vitornogueira It looks like there's a scripted field that is causing the problem, specifically doc[''] - have you tried addressing that? If the field is unused, perhaps you can simply deleted it and try again.

Hi @mattkime

I deleted all data from elastic search, our software services sent new data and the problem continued. We are using the default ELK stack settings, we have not made any modifications yet.

We are considering rebuilding Index Pattern apm- * to see if we have solved the problem.

We previously used version 6.x and the discover screen functioned normally.

Have you checked for the presence of scripted fields?

Yes, scripted fields were ok.

We rebuilt the Index Pattern (we deleted and created again) and it went back to work.

Thank you for your help!

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.