Exporting CSV from save search in dashboard shows blank values

Hello Team,

I was using kibana 7.13.1 and wanted to export CSV from saved search in dashboard.
But the exported CSV file only showed timestamp and column fields name but with blank values.
I also tried Discover -- open -- my search -- share -- generate CSV, it had the same problem (blank values) for those columns.

I found a similar discussion here, but my fields are mapped as text, which still occurred issues.

And also, the error log only showed warning messages like below:

{"type":"log","@timestamp":"2021-12-21T08:51:42-03:00","tags":["warning","plugins","reporting","csv_searchsource_immediate","csv_searchsource_immediate","execute-job"],"pid":2049,"message":"CSV may contain formulas whose values have been escaped"}

There was no error log about TypeError as issue mentioned.

I tried exporting smaller file that didn't larger than 10mb but the problem was still the same.
Is there any solution about these blank values?

Thank you,

This does look like this bug report Saved search won't export correctly from dashboard · Issue #101333 · elastic/kibana · GitHub
I think this should be fixed in recent versions. There were a lot of fixed in reporting recently.

Could you try to reproduce with a newer version?

Hi Dosov,

Thank you for your reply. It seems a bit the same with this bug report, but my save search from discover still has problem.

I'll try to update to newer version and reproduce again, and let you know what happen.


1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.