Fatal Error in Starting Kibana for Adding New Plugin

I created a plugin with plugin generator script in scripts/ folder (I used script in 7.10.1 with git checkout v7.10.1) and then i just copied it in kibana/plugins folder to check if it works on my kibana which it is version 7.10.1 too and I run the kibana and it raises an error .
I didn't change anything when i copied the plugin generated by script.

Error message:

log   [13:50:34.428] [fatal][root] { Error: Cannot find module '/usr/share/kibana/plugins/my_new_test_plugin5/server'
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:636:15)
    at Module.Hook._require.Module.require (/usr/share/kibana/node_modules/require-in-the-middle/index.js:61:29)
    at require (internal/modules/cjs/helpers.js:25:18)
    at PluginWrapper.getConfigDescriptor (/usr/share/kibana/src/core/server/plugins/plugin.js:130:30)
    at MergeMapSubscriber.plugin$.pipe [as project] (/usr/share/kibana/src/core/server/plugins/plugins_service.js:129:39)
    at MergeMapSubscriber._tryNext (/usr/share/kibana/node_modules/rxjs/internal/operators/mergeMap.js:67:27)
    at MergeMapSubscriber._next (/usr/share/kibana/node_modules/rxjs/internal/operators/mergeMap.js:57:18)
    at MergeMapSubscriber.Subscriber.next (/usr/share/kibana/node_modules/rxjs/internal/Subscriber.js:66:18)
    at FilterSubscriber._next (/usr/share/kibana/node_modules/rxjs/internal/operators/filter.js:52:30)
    at FilterSubscriber.Subscriber.next (/usr/share/kibana/node_modules/rxjs/internal/Subscriber.js:66:18) code: 'MODULE_NOT_FOUND' }

 FATAL  Error: Cannot find module '/usr/share/kibana/plugins/my_new_test_plugin5/server'

I just copied it in kibana/plugins folder , should I like install it or do something else ? I'm new to plugins and plugin development so I don't know exactly how I can install the generated plugin.

I've hit this error a few times before but can't remember exactly what I did to clear it.

I would attempt yarn cache clean then yarn kbn clean then yarn kbn bootstrap since it suggests not all dependancies are there.

Also typically when I do node scripts/generate_plugin NAME from the root directory it will copy it into the /plugin folder so you wouldn't need to move it.

oh no I test it in another kibana installed that its version is same as kibana which i cloned from kibana repo. should I run it from cloned kibana ?
how can I run it from another kibana that it has same version ?
like other public plugins that you can install on kibana

You would need to build it before installing it on another Kibana instance.

yarn build failed at first attempt should I like claen the cache or sth like that or not ?

What error did it give you? Did you run from within your /plugin/pluginName/ folder?