Fleet-Server Connection Cannot be Confirmed

I am in the process of trying to set up an Elastic stack and am running into problems with setting up a Fleet Server. My Elasticsearch and Kibana are all set up and performing well, but I need a Fleet Server to start setting up agents. The whole stack is being hosted on the same server, an ubuntu machine.

When I grab the provided commands (attached)

from my Kibana UI and try them in my console, I get the following error:

"log.origin":{"file.name":"cmd/enroll_cmd.go","file.line":807},"message":"Fleet Server - Error - failed version compatibility check with elasticsearch: tls: failed to verify certificate: x509: certificate signed by unknown authority","ecs.version":"1.6.0"}

I would greatly appreciate it if someone tried to walk me through what they think I might be doing wrong. I have tried adding '--insecure' after the token but it still triggers the same alert.

Thanks in advance.


Try reading this thread, it should have the same problem as yours.

Fleet Server - Error - x509: certificate signed by unknown authority - Elastic Stack / Elastic Agent - Discuss the Elastic Stack


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.