Gauge in visual builder


I'm really enjoying the visual builder features in 5.4.0, I think it's a really powerful addition to the product.

I've tried to marry up some of the Metricbeat data with a gauge and I'm getting weird results. The number in the middle of the gauge is correct but the circle is way off. Here's a screenshot:

Here's the source of the gauge:

The line chart visualization on the same dashboard shows the correct values too, I'm comparing it to the raw values in discover. The 'Time Series' version of this gauge looks correct.
I get the same sort of result when making a CPU gauge.

Is this a bug or something I'm misunderstanding?


For extra credit, on the Kibana 5.4.0 release notes page there's a screenshot of a demo dashboard which looks awesome. Has that been released for me to import into my own stack?

You need to go into panel options and set the max gauge value to 1. By default we use the max of the series because not all use cases are percentages.

Yep, that fixed it, thanks!

I was thinking about setting the max to default to 1 since it's probably more common that people will use percentages for the gauge then something else. Then the edge cases where people use something that's not a percentage they will need to unset the max or set it to something they think is reasonable.

I would really, really reaaaally like to have that dashboard. I'm trying to build the same thing but I get completely incorrect results. Would be nice to see the elastic team did it.

1 Like

Hi @simianhacker, don't suppose you have any sway to share that demo dashboard?

It's part of the Metricbeat dashboards that shipped with 5.4 I believe.

I didn't get it with 5.4 metricbeat install script :frowning:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.