Getting error when try to install kibana plugin

I'm trying to install "" package for kibana.

I tried to install with sudo :

sudo bin/kibana-plugin install

But I'm getting this error:

Kibana should not be run as root.  Use --allow-root to continue.

Then I try to install without sudo :

bin/kibana-plugin install

Now, I'm getting this error:

Plugin installation was unsuccessful due to error "ENOENT: no such file or directory, mkdir"

I also try this two command :

  1. su -s /bin/bash -c 'bin/kibana-plugin install'
  2. service kibana start 'bin/kibana-plugin install'

But still installation is unsuccessful.

What is the solution?

What version of Kibana are you running, and what distribution?

Kibana 7.7.0 and ubuntu 18.04 lts

Default or OSS Elasticsearch and Kibana?

It is default. I used this command for installation:
sudo apt-get install elasticsearch=7.7.0 && sudo apt-get install kibana=7.7.0

I tried with debian also but facing the same problem.

Then you get free security controls in there, you don't need to install this plugin.

I already use x-pack security. But I need Multitenancy feature. That's why I'm trying to install open distro. Please suggest me any solution so that I can use Multitenancy.

What do you mean by multitenancy?

Multi tenant is a feature that allow multiple user to access their own data only. I can do this with x-pack but in x-pack a user can see other user's index name.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.