HELP - Logstash isn't working!

Hey guys, ,

I'm in the process of installing Logstash, but I'm stuck halfway.

This is what's happening:

What am I supposed to do?
I really need to install it ASAP.


Please don't post pictures of text, they are difficult to read and some people may not be even able to see them. :slight_smile:

Why don't you run the latest?

Oh sorry, but I highlighted the errors appearing :slight_smile:

I installed Kibana and ES version 5.2.2, so I really don't want to update everything all over again. :confused:

Why do you need to update everything, just use a more recent version of LS.

But isn't everything supposed to be the same version?

I'm not sure if installing LS 5.3 will fix this problem, though.

Your URL shows you are trying to install 2.2?

Yeah, I just typed 'sudo apt-get install logstash' and it showed that it's trying to install 2.2.

Right, that's my point.

I'd suggest you check your repository settings -


Yea, as stated earlier, it looks like the repository definition is incorrect. Below should be the one to add to /etc/apt/sources.list or create your own file under /etc/apt/sources.list.d/

deb stable main

Thanks a lot guys, I passed the point where I was stuck.
But now I'm stuck elsewhere...

It says Logstash is already running, then it says file doesn't exist.

Sooo weird....

Again. please don't post pictures of text, they are difficult to read and some people may not be even able to see them.

What OS are you on? What version?

I'm on Ubuntu 14.05.

The output of sudo service logstash configtest says "unrecognized service".

And the output of sudo service logstash start says "job is already running".

That's not a valid argument afaik.

What are you trying to do here?

I'm following THIS documentation by DO.

This is what it says:

"Test your Logstash configuration with this command:

[ sudo service logstash configtest ]

It should display Configuration OK if there are no syntax errors. Otherwise, try and read the error output to see what's wrong with your Logstash configuration."

I'm trying to execute this command:

"sudo update-rc.d logstash defaults 96 9"

this is the output:

"update-rc.d: /etc/init.d/logstash: file does not exist"

What's missing here?

Why are you running an old tutorial (more than 2 years old, in fact) for an old version of Logstash, instead of getting the documentation from the source?

You would have learned that Logstash v5 automatically detects the correct init system (SysV, upstart, systemd) and installs the appropriate scripts.

If you don't like starting Logstash with upstart (sudo initctl start logstash) and still want it to use SysV style, you can force-create a SysV init script by running:

/usr/share/logstash/bin/system-install /etc/logstash/startup.options sysv 

The commands you attempted above may work after that.


I tried following both documentations, none of them worked.

When I run [quote="theuntergeek, post:16, topic:80614"]
sudo initctl start logstash
[/quote] it says command not found.

And when I run [quote="theuntergeek, post:16, topic:80614"]
/usr/share/logstash/bin/system-install /etc/logstash/startup.options sysv
[/quote] it says unable to install system startup script for Logstash.

What's the problem here?

If initctl is not present on Ubuntu 14.04, you must have a setup that differs from default Ubuntu 14.04. The initctl command is present on Ubuntu 14.04 by default:

root@ubuntu1404-pkg-test:~$ initctl
initctl: missing command
Try `initctl --help' for more information.

It would be helpful if you would cut and paste the errors here between rows of triple back-ticks, like this:


Without output, it will be difficult—if not impossible—to resolve your issue.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.