How to check the "doc_value" and "field data" in Kibana


(Gayathri TR) #1

Hi Team,

I have added below things in mapping:

"doc_values" : true
and
"fielddata": {
"loading" : "eager_global_ordinals"
}
inorder to resolve the space issues with the String fields....
But Iam not getting how to check these got reflected or not....
How to check the values of these in Kibana?


(Lee Drengenberg) #2

Hi Gayathri,

Are you trying to reduce the space string fields use? Adding "doc_values" : true (which is the default) increases the required disk space. But it's true by default so that you can sort and aggregation by those fields. To save space, you can set it to false on fields that you don't need to sort or aggregate on.
https://www.elastic.co/guide/en/elasticsearch/reference/current/doc-values.html

Kibana doesn't know if doc_values are on. I think if you try to sort or aggregate on a field with "doc_values" : false Kibana would show the error that Elasticsearch sends.

As I understand the field data settings, you could disable them to save JVM heap space;
https://www.elastic.co/guide/en/elasticsearch/reference/2.3/fielddata.html

The loading setting "eager_global_ordinals" only controls when the data is loaded.
But again in this case, I don't think Kibana knows if field data is loaded or not. You might see an error in Kibana if you try to sort or aggregate on values in analyzed strings and you have disabled field data on them.


(Gayathri TR) #3

Thank u Lee


(system) #4