How to disable pie filter for some metric


(CyberBobak) #1

Hello,

I've in dashboard 2 metrics, every has different index source & pie which is using the second index.The pie is filtering on field 'severity' which exist only in second index. Issue is that when I click on the pie then metric value of first metric, (no 'severity' field) is always reset to 0.

How can I exclude that the filter will not be applied to first metric ?
I tried to set on pie filter: 'if severity exists'.

Than You


(Christian Dahlqvist) #2

I believe you can handle this through the courier:ignoreFilterIfFieldNotInIndex parameter under Advanced Options.


(CyberBobak) #3

It's still not working :frowning: Some other settings ?


(CyberBobak) #4

It's interesting, field 'severity' has only two values, 4 & 5.
When I remove manually the filter generated by clicking on pie ('severity is 4' ) and set reverse logic: 'severity is not 5' then the value for the metric will not change.I forgot to mention Kibana ver: 6.4.3.


(CyberBobak) #5

I installed fresh version of Kibana:

kibana-6.5.1-1.x86_64
elasticsearch-6.5.1-1.noarch
logstash-6.5.1-1.noarch

set 'courier:ignoreFilterIfFieldNotInIndex' to true in 'Adnvanced settings' and the issue is same.

May I ask some experienced user how to fix it ?

Thank You