How to disable the autocreation .monitoring index in Elasticsearch

When we start the ES and kibana its automatically created dot(.) monitoring index in elasticsearch so its very frustrated for me . Is there any options to disable or enable when we need that.

Elastic version - 6.3.2
Kibana version - 6.3.2

es

RDid you enable monitoring?

I think that in the latest version it's not created anymore unless you enable monitoring.

Thanks for your reply dadoonet.

But i like to stop this dot monitoring file in Elastic version-5.5.2 and kibana 5.5.2
Because this xpack monitoring is only in 6x version but in 5x version is also created dot monitoring file .

Is there any options to disable or enable when we need that in 5x version.

I tried 5x verion

GET /_cluster/settings

response i got
{
"persistent: {}.
"transient: {}
}

xpack monitoring is also available in 5.x. What do you mean ?

How to disable dot monitoring in 5.x version .

I tried 5.x version

GET /_cluster/settings

response i got
{
"persistent" : {},
"transient" : {}
}

How to disable dot monitoring in 5.x version .

Have a look at https://www.elastic.co/guide/en/x-pack/5.6/xpack-settings.html

But you mentioned at the begining that you are using 6.3 so I'm confused.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.