How to install/use x-pack on OSX Homebrew (OSS) version?


(Yehosef) #1

There was a discussion at [6.3.0] homebrew recipe
about getting elasticsearch working again with homebrew - and it seems it's now working. It seems.

The problem is that now that I installed the homebrew version (which is based on the OSS distribution), I can't install x-pack (via elasticsearch-plugin install x-pack). I understand that x-pack is not separate so this doesn't work anymore (at least like this) but is there some other way to get x-pack working on OSX?

I don't really have to use homebrew - it's just very convenient and always "just worked" before the whole change to "open up x-pack". Since that change, it's "just not worked". Is there some other recommended way people have to use elasticsearch on OSX? Or someway to get x-pack working again?

I use my MBP for local development. I could resort to a VM/docker, but it's so much heavier than just running ES locally (and that always worked).


(Alexander Reelsen) #2

right now you need to install Elasticsearch with x-pack manually. We will look into providing our own taps in the future, so that you are not dependent on the homebrew repositories. There is no concrete time frame for this though.


(Yehosef) #3

Thanks - but how do I do that? In the past when I installed elasticsearch with homebrew (and it didn't include x-pack) I would install with elasticsearch-plugin install x-pack as I mentioned. But that doesn't work now.

I don't mind installing it manually - but how do I do it?


(Alexander Reelsen) #4

I was referring to download the zip file from the downloads page

--Alex


(Yehosef) #5

ok- can you explain, or are there instructions on how that would look on OSX? Especially for someone coming from homebrew. Ideally I'd like the config/data/logging directories to remain the same so I can use migrate without losing data or config.

This would also be needed/nice for kibana.

Or maybe you should just create a DMG - maybe that would be easier. That's what Dremio does and it seems to work well.


(Alexander Reelsen) #6

See https://www.elastic.co/guide/en/elasticsearch/reference/6.4/zip-targz.html and https://www.elastic.co/guide/en/kibana/6.4/targz.html


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.