How to migrate from Kibana 4.5.0 to Kibana 5.0.0?


(Jay Dihenkar) #1

We're currently running Elasticsearch 2.3.3 and Kibana 4.5.0. We are migrating to Elasticsearch 5.0.0 and Kibana 5.0.0. So far Elasticsearch upgrade is smooth by following the migration helper. But having issues with Kibana dashboards [ index mapping not refreshing in management for logstash, dashboards are saying bad request from Elasticsearch 400 ].


(Mark Walkom) #2

Can you show us the complete error?


(Jay Dihenkar) #3

This ERR "Bad Request" :

This is what I'm getting in Kibana Logs :

respons [09:44:59.020] POST /elasticsearch/.kibana/index-pattern/%5Blogstash-%5DYYYY.MM.DD 400 624ms - 9.0B


(Jay Dihenkar) #4

The point is when I go to management page indices and select [logstash-]YYYY.MM.DD, It's not allowing me to refresh index.

In Kibana :

respons [09:54:44.029] POST /elasticsearch/.kibana/index-pattern/%5Blogstash-%5DYYYY.MM.DD 400 1137ms - 9.0B


(Jay Dihenkar) #5

Further I deleted the Kibana Index and then I tried to create the logstash index again :

It again fails with 400 code as above

and gives this :


(Christian Dahlqvist) #6

AS pointed out in the large orange blob on the screen, it is now recommended to use wildcard patterns in Kibana rather than the older style date patterns. Have you tried specifying the index pattern as logstash-* as recommended?


(Jay Dihenkar) #7

respons [10:11:33.375] POST /elasticsearch/.kibana/index-pattern/logstash-* 400 3495ms - 9.0B

Again a 400.

But something different, now it went all BLANK on all pages :


(Jay Dihenkar) #8

curl -XGET -vv 'http://data3.dev.evivehealth.com:9201/.kibana/index-pattern/logstash-*'

  • Hostname was NOT found in DNS cache
  • Trying 10.13.1.35...
  • Connected to data3.dev.evivehealth.com (10.13.1.35) port 9201 (#0)

GET /.kibana/index-pattern/logstash-* HTTP/1.1
User-Agent: curl/7.37.0
Host: data3.dev.evivehealth.com:9201
Accept: /

< HTTP/1.1 200 OK
< content-type: application/json; charset=UTF-8
< content-length: 151
<

  • Connection #0 to host data3.dev.evivehealth.com left intact
    {"_index":".kibana","_type":"index-pattern","_id":"logstash-","_version":1,"found":true,"_source":{"title":"logstash-","timeFieldName":"@timestamp"}}

ES is returning 200 and not 400. Is something not configured properly at kibana?

My Kibana yaml says :

elasticsearch.url: "http://data3.dev.evivehealth.com:9201/"

rest all settings related to es are deafult.


(Jay Dihenkar) #9

Adding to this I tried now putting nginx in front of ES and see what response am getting from ES

Suprisingly :

for : respons [11:14:35.828] POST /elasticsearch/.kibana/index-pattern/logstash-* 400 928ms - 9.0B
I'm getting this in nginx :

10.13.1.35 - - [11/Nov/2016:16:47:52 +0530] "GET /logstash-*/_mapping/field/*?ignore_unavailable=false&allow_no_indices=false&include_defaults=true HTTP/1.1" 200 14294248 "-" "-" "10.14.1.187" 10.13.1.35 - - [11/Nov/2016:16:47:54 +0530] "POST /logstash-*/_field_stats?fields=*&allow_no_indices=false HTTP/1.1" 200 1712898 "-" "-" "-"

SO ES is indeed returning 200. something wrong in kibana? [ All requests getting 200 ]


(Spencer Alger) #10

This sounds a lot like a misconfigured proxy. Have you tried connecting Kibana directly to elasticsearch?


(Jay Dihenkar) #11

As you see in my previous updates, I was not using proxy and then I configured nginx as a proxy.

Moreover after debugging and trials and errors It somehow got resolved when removed a logstash index which I imported from es2.3 to es5.0.


(system) #12

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.